Thomas Lundquist writes:
authorEric Andersen <andersen@codepoet.org>
Tue, 12 Jul 2005 19:53:12 +0000 (19:53 -0000)
committerEric Andersen <andersen@codepoet.org>
Tue, 12 Jul 2005 19:53:12 +0000 (19:53 -0000)
If I understand you correctly, you want the ncurses development headers
on the target.

a patch for this (named target_headers.patch and includes similar
options for a few other libs in buildroot) can be found at:

http://www.zelow.no/floppyfw/download/Development/Patches/buildroot/

(a few packages there aswell)

it will add an option to put headers on target for ncurses, zlib and
openssl.

Thomas.

package/e2fsprogs/e2fsprogs.mk
package/ncurses/Config.in
package/ncurses/ncurses.mk
package/openssl/Config.in
package/openssl/openssl.mk
package/util-linux/util-linux.mk
package/zlib/Config.in
package/zlib/zlib.mk

index dace74ba27ab13dbcd02d5df12630afd3d528270..ef2afa414ab080acdeb47aea5a2ec9d09abd730e 100644 (file)
@@ -46,6 +46,7 @@ $(E2FSPROGS_DIR)/.configured: $(E2FSPROGS_DIR)/.unpacked
                --disable-resizer --enable-fsck \
                 --disable-e2initrd-helper \
                --without-catgets $(DISABLE_NLS) \
+               $(DISABLE_LARGEFILE) \
        );
        touch  $(E2FSPROGS_DIR)/.configured
 
index fec54c19ebe25cabace752b6c08c71abcc5aa193..9a507686bb6786dbab2f434402efff242dfd32f4 100644 (file)
@@ -6,3 +6,10 @@ config BR2_PACKAGE_NCURSES
          curses in System V Release 4.0, and more.
 
          http://www.gnu.org/software/ncurses/
+
+config BR2_PACKAGE_NCURSES_TARGET_HEADERS
+       bool "ncurses headers in target"
+       default n
+       depends on BR2_PACKAGE_NCURSES
+       help
+         Ncurses headers in target
index 106f773b048dce3ddcf834e37703f53045ad76b0..8648521dc0577936b35d7c2cba8858eb30aeb8a8 100644 (file)
@@ -149,3 +149,6 @@ ncurses-dirclean:
 ifeq ($(strip $(BR2_PACKAGE_NCURSES)),y)
 TARGETS+=ncurses
 endif
+ifeq ($(strip $(BR2_PACKAGE_NCURSES_TARGET_HEADERS)),y)
+TARGETS+=ncurses-headers
+endif
index d13768d05ed5a717801956cc4be25aa78e096f85..6012fb4965756e884dde6484bf0a59a9cebd0f97 100644 (file)
@@ -8,3 +8,10 @@ config BR2_PACKAGE_OPENSSL
          full-strength general-purpose cryptography library.
 
          http://www.openssl.org/
+
+config BR2_PACKAGE_OPENSSL_TARGET_HEADERS
+       bool "openssl headers in target"
+       default n
+       depends on BR2_PACKAGE_OPENSSL
+       help
+         Put openssl headers in the target.
index 4c82060a4e7b0a9cdd5225302c1e1ffdcacd15b7..af0266ea92121c10d46df5a06e6708784492a44e 100644 (file)
@@ -25,7 +25,7 @@ $(OPENSSL_DIR)/.unpacked: $(DL_DIR)/$(OPENSSL_SOURCE)
 
 $(OPENSSL_DIR)/Makefile: $(OPENSSL_DIR)/.unpacked
        (cd $(OPENSSL_DIR); \
-       CFLAGS="-DOPENSSL_NO_KRB5 -DOPENSSL_NO_IDEA -DOPENSSL_NO_MDC2 -DOPENSSL_NO_RC5" \
+       CFLAGS="-DOPENSSL_NO_KRB5 -DOPENSSL_NO_IDEA -DOPENSSL_NO_MDC2 -DOPENSSL_NO_RC5 $(TARGET_CFLAGS)" \
        PATH=$(TARGET_PATH) ./Configure linux-$(ARCH) --prefix=/ \
                --openssldir=/usr/lib/ssl -L$(STAGING_DIR)/lib -ldl \
                -I$(STAGING_DIR)/include $(OPENSSL_OPTS) no-threads \
@@ -85,3 +85,6 @@ openssl-dirclean:
 ifeq ($(strip $(BR2_PACKAGE_OPENSSL)),y)
 TARGETS+=openssl
 endif
+ifeq ($(strip $(BR2_PACKAGE_OPENSSL_TARGET_HEADERS)),y)
+TARGETS+=openssl-headers
+endif
index 879d8009fbdce1fb299406ce0e5b4fee10f2e9da..6a5a6891cb5f3e9a801933ebc9c008da9df15434 100644 (file)
@@ -21,6 +21,9 @@ $(UTIL-LINUX_DIR)/.unpacked: $(DL_DIR)/$(UTIL-LINUX_SOURCE) $(DL_DIR)/$(UTIL-LIN
        $(UTIL-LINUX_CAT) $(DL_DIR)/$(UTIL-LINUX_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
        $(UTIL-LINUX_CAT) $(DL_DIR)/$(UTIL-LINUX_PATCH) | patch -p1 -d $(UTIL-LINUX_DIR)
        toolchain/patch-kernel.sh $(UTIL-LINUX_DIR) package/util-linux/ util-linux\*.patch
+ifneq ($(BR2_LARGEFILE),y)
+       $(SED) "/D_FILE_OFFSET_BITS/ d" $(UTIL-LINUX_DIR)/MCONFIG
+endif
        touch $(UTIL-LINUX_DIR)/.unpacked
 
 $(UTIL-LINUX_DIR)/.configured: $(UTIL-LINUX_DIR)/.unpacked
@@ -40,6 +43,7 @@ $(UTIL-LINUX_DIR)/.configured: $(UTIL-LINUX_DIR)/.unpacked
                --mandir=/usr/man \
                --infodir=/usr/info \
                $(DISABLE_NLS) \
+               $(DISABLE_LARGEFILE) \
                ARCH=$(ARCH) \
        );
        $(SED) "s,^INSTALLSUID=.*,INSTALLSUID=\\$$\(INSTALL\) -m \\$$\(BINMODE\)," \
index e39e8abb05111bf006c15ccff9412ca87c6d11ff..5b85ff7e484cbf8b7441fa991ecd8d1a0df11dc0 100644 (file)
@@ -6,3 +6,10 @@ config BR2_PACKAGE_ZLIB
          gzip and libpng.
 
          http://www.gzip.org/zlib/
+
+config BR2_PACKAGE_ZLIB_TARGET_HEADERS
+       bool "zlib headers in target"
+       default n
+       depends on BR2_PACKAGE_ZLIB
+       help
+         Put headers files in the target.
index 4b8f92d55aaf1e4bea9516b4db90ade92842954b..978024a895f39c9c1d15c74fb5f638c7eb17cb60 100644 (file)
@@ -79,3 +79,6 @@ zlib-dirclean:
 ifeq ($(strip $(BR2_PACKAGE_ZLIB)),y)
 TARGETS+=zlib
 endif
+ifeq ($(strip $(BR2_PACKAGE_ZLIB_TARGET_HEADERS)),y)
+TARGETS+=zlib-headers
+endif