mtdev2tuio: new package
authorStephan Hoffmann <sho@relinux.de>
Thu, 30 Aug 2012 02:56:38 +0000 (04:56 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 30 Aug 2012 03:09:50 +0000 (05:09 +0200)
mtdev2tuio is a simple application for converting touch events
to the standart TUIO 1.1 protocol.

https://github.com/olivopaolo/mtdev2tuio

[thomas.petazzoni@free-electrons.com: use TARGET_CONFIGURE_OPTS, fix
indentation, add dependency on thread support in toolchain]

Signed-off-by: Stephan Hoffmann <sho@relinux.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/mtdev2tuio/Config.in [new file with mode: 0644]
package/mtdev2tuio/mtdev2tuio.mk [new file with mode: 0644]

index 5b4788fbf891a22c41084b260ed68fbdb392df59..e1295220842fed2d47678b9d101e4f9149d0f5c8 100644 (file)
@@ -469,6 +469,7 @@ source "package/libtpl/Config.in"
 source "package/liburcu/Config.in"
 source "package/linux-pam/Config.in"
 source "package/lttng-libust/Config.in"
+source "package/mtdev2tuio/Config.in"
 source "package/orc/Config.in"
 source "package/poco/Config.in"
 source "package/protobuf/Config.in"
diff --git a/package/mtdev2tuio/Config.in b/package/mtdev2tuio/Config.in
new file mode 100644 (file)
index 0000000..74453c4
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_MTDEV2TUIO
+       bool "mtdev2tuio"
+       select BR2_PACKAGE_LIBLO
+       select BR2_PACKAGE_MTDEV
+       depends on BR2_TOOLCHAIN_HAS_THREADS # liblo
+       help
+         mtdev2tuio is a simple application for converting touch
+         events captured from libmtdev to TUIO 1.1
+
+         https://github.com/olivopaolo/mtdev2tuio
+
+comment "mtdev2tuio requires thread support in toolchain"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/mtdev2tuio/mtdev2tuio.mk b/package/mtdev2tuio/mtdev2tuio.mk
new file mode 100644 (file)
index 0000000..a86c0bf
--- /dev/null
@@ -0,0 +1,29 @@
+#############################################################
+#
+# mtdev2tuio
+#
+#############################################################
+MTDEV2TUIO_VERSION = e1e7378d86
+MTDEV2TUIO_SITE = git://github.com/olivopaolo/mtdev2tuio.git
+MTDEV2TUIO_DEPENDENCIES = mtdev liblo
+MTDEV2TUIO_LICENSE = GPLv3+
+MTDEV2TUIO_LICENSE_FILES = COPYING
+
+# mtdev2tuio Makefile misuses $(LD) as gcc, so we need to override LD
+# here.
+define MTDEV2TUIO_BUILD_CMDS
+       $(MAKE) \
+               $(TARGET_CONFIGURE_OPTS) \
+               LD="$(TARGET_CC)" \
+               -C $(@D)
+endef
+
+define MTDEV2TUIO_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/mtdev2tuio $(TARGET_DIR)/usr/bin/mtdev2tuio
+endef
+
+define MTDEV2TUIO_CLEAN_CMDS
+       $(MAKE) -C $(@D) clean
+endef
+
+$(eval $(generic-package))