evemu: new package
authorNaumann Andreas <ANaumann@ultratronik.de>
Wed, 8 Jan 2014 16:05:08 +0000 (17:05 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 8 Jan 2014 22:10:01 +0000 (23:10 +0100)
[Peter: don't try to generate manpages even if host has asciidoc]
Signed-off-by: Andreas Naumann <anaumann@ultratronik.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/evemu/Config.in [new file with mode: 0644]
package/evemu/evemu.mk [new file with mode: 0644]

index e502cde456eda51ff031e299346a4303c8166cee..8af6a1e71525a28acd3b0d47072dfd428f40cc09 100644 (file)
@@ -277,6 +277,7 @@ source "package/dmraid/Config.in"
 source "package/dvb-apps/Config.in"
 source "package/dvbsnoop/Config.in"
 source "package/eeprog/Config.in"
+source "package/evemu/Config.in"
 source "package/evtest/Config.in"
 source "package/fan-ctrl/Config.in"
 source "package/fconfig/Config.in"
diff --git a/package/evemu/Config.in b/package/evemu/Config.in
new file mode 100644 (file)
index 0000000..07b7174
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_EVEMU
+       bool "evemu"
+       select BR2_PACKAGE_LIBEVDEV
+       help
+         evemu records and replays device descriptions and events
+
+         http://www.freedesktop.org/wiki/Evemu/
diff --git a/package/evemu/evemu.mk b/package/evemu/evemu.mk
new file mode 100644 (file)
index 0000000..38b792d
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# evemu
+#
+################################################################################
+
+EVEMU_VERSION = 1.0.10
+EVEMU_SITE = http://cgit.freedesktop.org/evemu/snapshot
+EVEMU_LICENSE = LGPLv3 (library), GPLv3 (tools)
+EVEMU_LICENSE_FILES = COPYING COPYING.GPL3
+
+# asciidoc used to generate manpages, which we don't need, and if it's
+# present on the build host, it ends getting called with our host-python
+# which doesn't have all the needed modules enabled, breaking the build
+EVEMU_CONF_ENV = ac_cv_path_ASCIIDOC=""
+
+# Uses PKG_CHECK_MODULES() in configure.ac
+EVEMU_DEPENDENCIES = host-pkgconf libevdev
+
+# Needs Python to generate a wrapper
+EVEMU_DEPENDENCIES += host-python
+
+# package source code coming from git, so it doesn't have generated
+# configure and Makefile.in
+EVEMU_AUTORECONF = YES
+
+$(eval $(autotools-package))