tzdata: reorder zone list to avoid missing links
authorMichel Marti <mma@objectxp.com>
Fri, 8 Apr 2016 08:23:27 +0000 (10:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 19 Apr 2016 21:11:49 +0000 (23:11 +0200)
The 'backward' zone references entries from other zones (e.g. Pacific/*)
that have not yet been compiled, leading to missing links. To fix this,
take-over the zone list sort order from upstream 'tzdata' and also ensure
that make fails if zic terminates with a non-zero exit code.

Signed-off-by: Michel Marti <mma@objectxp.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tzdata/tzdata.mk

index 69bae030b84b83c8db6a70f69e238c4daa1b4ce8..f50a83c411bc9d65df9f9ae0740d66acaed8fa6f 100644 (file)
@@ -12,9 +12,11 @@ TZDATA_DEPENDENCIES = host-tzdata
 HOST_TZDATA_DEPENDENCIES = host-zic
 TZDATA_LICENSE = Public domain
 
+# Take care when re-ordering this list since this might break zone
+# dependencies
 TZDATA_DEFAULT_ZONELIST = \
-       africa antarctica asia australasia backward etcetera \
-       europe factory northamerica pacificnew southamerica
+       africa antarctica asia australasia europe northamerica \
+       southamerica pacificnew etcetera backward systemv factory
 
 ifeq ($(call qstrip,$(BR2_TARGET_TZ_ZONELIST)),default)
 TZDATA_ZONELIST = $(TZDATA_DEFAULT_ZONELIST)
@@ -49,8 +51,8 @@ endef
 define HOST_TZDATA_BUILD_CMDS
        (cd $(@D); \
                for zone in $(TZDATA_ZONELIST); do \
-                       $(ZIC) -d _output/posix -y yearistype.sh $$zone; \
-                       $(ZIC) -d _output/right -L leapseconds -y yearistype.sh $$zone; \
+                       $(ZIC) -d _output/posix -y yearistype.sh $$zone || exit 1; \
+                       $(ZIC) -d _output/right -L leapseconds -y yearistype.sh $$zone || exit 1; \
                done; \
        )
 endef