package/mpd: add libsidplay2 optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 14 Aug 2020 21:19:37 +0000 (23:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 18 Aug 2020 21:49:04 +0000 (23:49 +0200)
libsidplay2 is an optional dependency since version 0.15.0 and
https://github.com/MusicPlayerDaemon/MPD/commit/1136f6fb7a2a6a0a5bfba0dcf99410d1bbf04252

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mpd/Config.in
package/mpd/mpd.mk

index 791fb0f54af68d4bbfae1d1fb2381ea3bb3a73ad..baaaa7f1aea306e6b92e8f51618933222e93f334 100644 (file)
@@ -165,6 +165,12 @@ config BR2_PACKAGE_MPD_OPUS
          Enable opus input support.
          Select this if you want to play back OPUS encoded files.
 
+config BR2_PACKAGE_MPD_SIDPLAY
+       bool "sidplay"
+       select BR2_PACKAGE_LIBSIDPLAY2
+       help
+         Enable C64 SID support.
+
 config BR2_PACKAGE_MPD_TREMOR
        bool "tremor"
        depends on !BR2_PACKAGE_MPD_VORBIS
index a3b90aa55f6903363e6ada2109e175253aa3e79c..51bc1719a70d51cbe97ec17b99485c87a4a1f159 100644 (file)
@@ -241,6 +241,13 @@ else
 MPD_CONF_OPTS += -Dshout=disabled
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_SIDPLAY),y)
+MPD_DEPENDENCIES += libsidplay2
+MPD_CONF_OPTS += -Dsidplay=enabled
+else
+MPD_CONF_OPTS += -Dsidplay=disabled
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_SOUNDCLOUD),y)
 MPD_DEPENDENCIES += yajl
 MPD_CONF_OPTS += -Dsoundcloud=enabled