package/xbmc-addon-xvdr: rename to kodi-addon-xvdr
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 23 Dec 2014 17:46:33 +0000 (18:46 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Dec 2014 18:58:29 +0000 (19:58 +0100)
Following the rename of the XBMC project to Kodi, this commit renames
the xbmc-addon-xvdr package to kodi-addon-xvdr, and adds the
appropriate Config.in.legacy handling.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/kodi-addon-xvdr/Config.in [new file with mode: 0644]
package/kodi-addon-xvdr/kodi-addon-xvdr.mk [new file with mode: 0644]
package/kodi/Config.in
package/xbmc-addon-xvdr/Config.in [deleted file]
package/xbmc-addon-xvdr/xbmc-addon-xvdr.mk [deleted file]

index 653eeac7278201968648573489fad19185a41d7d..de2c0bad6895472589f47c7bcee264fff5834083 100644 (file)
@@ -102,6 +102,13 @@ endif
 
 comment "Legacy options removed in 2015.02"
 
+config BR2_PACKAGE_XBMC_ADDON_XVDR
+       bool "xbmc options have been renamed"
+       select BR2_LEGACY
+       select BR2_PACKAGE_KODI_ADDON_XVDR
+       help
+         The XBMC media center project was renamed to Kodi entertainment center
+
 config BR2_PACKAGE_XBMC_PVR_ADDONS
        bool "xbmc options have been renamed"
        select BR2_LEGACY
diff --git a/package/kodi-addon-xvdr/Config.in b/package/kodi-addon-xvdr/Config.in
new file mode 100644 (file)
index 0000000..6e713af
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_KODI_ADDON_XVDR
+       bool "kodi-addon-xvdr"
+       help
+         This is a PVR add-on for Kodi to add VDR (http://tvdr.de/)
+         as a TV/PVR Backend to Kodi.
+
+         It adds support for Live TV watching, replaying of Recordings,
+         programming Timers and EPG TV Guide to use on same computer or
+         over the Network.
+
+         https://github.com/pipelka/xbmc-addon-xvdr
+
+         Note: since the VDR server is not packaged in Buildroot, using
+         this addon requires that a remote VDR server be used.
diff --git a/package/kodi-addon-xvdr/kodi-addon-xvdr.mk b/package/kodi-addon-xvdr/kodi-addon-xvdr.mk
new file mode 100644 (file)
index 0000000..14b08fe
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# kodi-addon-xvdr
+#
+################################################################################
+
+# This cset is on master. When a Gotham branch is made, we should
+# follow it, as incompatible changes in the plugins API can happen
+# on the master branch.
+KODI_ADDON_XVDR_VERSION = 82b5093ad33847f97a978cb620c9a87d2dbcf7eb
+KODI_ADDON_XVDR_SITE = $(call github,pipelka,xbmc-addon-xvdr,$(KODI_ADDON_XVDR_VERSION))
+KODI_ADDON_XVDR_LICENSE = GPLv2+
+KODI_ADDON_XVDR_LICENSE_FILES = COPYING
+
+# There's no ./configure in the git tree, we need to generate it
+# kodi-addon-xvdr uses a weird autogen.sh script, which
+# is even incorrect (it's missing the #! ) Sigh... :-(
+# Fortunately, with our little patch, it autoreconfs nicely! :-)
+KODI_ADDON_XVDR_AUTORECONF = YES
+
+# This really is a runtime dependency, but we need KODI to be installed
+# first, since we'll install files in KODI's directories _after_ KODI has
+# installed his own files
+KODI_ADDON_XVDR_DEPENDENCIES = kodi
+
+$(eval $(autotools-package))
index d1286b7eadcd07c7e4dd44eeb7225ad037e4a0b9..4bc017873a8235863f0d2afea10b0e77f2b2b380 100644 (file)
@@ -237,7 +237,7 @@ config BR2_PACKAGE_KODI_WAVPACK
 
 comment "Kodi addons"
 
-source "package/xbmc-addon-xvdr/Config.in"
+source "package/kodi-addon-xvdr/Config.in"
 source "package/kodi-pvr-addons/Config.in"
 
 endif # BR2_PACKAGE_KODI
diff --git a/package/xbmc-addon-xvdr/Config.in b/package/xbmc-addon-xvdr/Config.in
deleted file mode 100644 (file)
index 7329a9a..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-config BR2_PACKAGE_XBMC_ADDON_XVDR
-       bool "xbmc-addon-xvdr"
-       help
-         This is a PVR add-on for XBMC to add VDR (http://tvdr.de/)
-         as a TV/PVR Backend to XBMC.
-
-         It adds support for Live TV watching, replaying of Recordings,
-         programming Timers and EPG TV Guide to use on same computer or
-         over the Network.
-
-         https://github.com/pipelka/xbmc-addon-xvdr
-
-         Note: since the VDR server is not packaged in Buildroot, using
-         this addon requires that a remote VDR server be used.
diff --git a/package/xbmc-addon-xvdr/xbmc-addon-xvdr.mk b/package/xbmc-addon-xvdr/xbmc-addon-xvdr.mk
deleted file mode 100644 (file)
index 16f3a0d..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-################################################################################
-#
-# xbmc-addon-xvdr
-#
-################################################################################
-
-# This cset is on master. When a Gotham branch is made, we should
-# follow it, as incompatible changes in the plugins API can happen
-# on the master branch.
-XBMC_ADDON_XVDR_VERSION = 82b5093ad33847f97a978cb620c9a87d2dbcf7eb
-XBMC_ADDON_XVDR_SITE = $(call github,pipelka,xbmc-addon-xvdr,$(XBMC_ADDON_XVDR_VERSION))
-XBMC_ADDON_XVDR_LICENSE = GPLv2+
-XBMC_ADDON_XVDR_LICENSE_FILES = COPYING
-
-# There's no ./configure in the git tree, we need to generate it
-# xbmc-addon-xvdr uses a weird autogen.sh script, which
-# is even incorrect (it's missing the #! ) Sigh... :-(
-# Fortunately, with our little patch, it autoreconfs nicely! :-)
-XBMC_ADDON_XVDR_AUTORECONF = YES
-
-# This really is a runtime dependency, but we need XBMC to be installed
-# first, since we'll install files in XBMC's directories _after_ XBMC has
-# installed his own files
-XBMC_ADDON_XVDR_DEPENDENCIES = kodi
-
-$(eval $(autotools-package))