package: add bustle dbus monitor package
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 22 Jan 2013 14:55:55 +0000 (15:55 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 22 Jan 2013 14:56:57 +0000 (15:56 +0100)
Only builds the capture tool, not the (host) graphical viewer.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/bustle/Config.in [new file with mode: 0644]
package/bustle/bustle.mk [new file with mode: 0644]

index 39e2ec723d877942cf17ea6cee90b74a67f57f7a..c4e5ad5f64f44d44eb6ad232484d3c249c808b7b 100644 (file)
@@ -53,6 +53,7 @@ source "package/automake/Config.in"
 source "package/binutils/Config.in"
 source "package/bison/Config.in"
 source "package/bsdiff/Config.in"
+source "package/bustle/Config.in"
 source "package/ccache/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/coreutils/Config.in"
diff --git a/package/bustle/Config.in b/package/bustle/Config.in
new file mode 100644 (file)
index 0000000..2a2a2c1
--- /dev/null
@@ -0,0 +1,22 @@
+config BR2_PACKAGE_BUSTLE
+       bool "bustle"
+       select BR2_PACKAGE_LIBPCAP
+       select BR2_PACKAGE_LIBGLIB2
+       depends on BR2_USE_WCHAR # libglib2
+       depends on BR2_PACKAGE_DBUS # runtime
+       help
+         Bustle is a better dbus-monitor! It records and draws
+         sequence diagrams of D-Bus activity, showing signal
+         emissions, method calls and their corresponding returns,
+         with timestamps for each individual event and the duration
+         of each method call. This can help you check for unwanted
+         D-Bus traffic, and pinpoint why your D-Bus-based application
+         isn't performing as well as you like.
+
+         This only installs the command line bustle-pcap tool, not
+         the graphical viewer.
+
+         http://www.willthompson.co.uk/bustle/
+
+comment "bustle requires a toolchain with WCHAR support"
+       depends on !BR2_USE_WCHAR
diff --git a/package/bustle/bustle.mk b/package/bustle/bustle.mk
new file mode 100644 (file)
index 0000000..88d49b6
--- /dev/null
@@ -0,0 +1,23 @@
+#############################################################
+#
+# bustle
+#
+#############################################################
+
+BUSTLE_VERSION = 0.4.2
+BUSTLE_SITE = http://www.willthompson.co.uk/bustle/releases/$(BUSTLE_VERSION)/
+BUSTLE_LICENSE = LGPLv2.1+
+BUSTLE_LICENSE_FILES = LICENSE
+BUSTLE_DEPENDENCIES = libglib2 libpcap host-pkgconf
+
+define BUSTLE_BUILD_CMDS
+       PATH=$(TARGET_PATH) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
+               PCAP_FLAGS='-lpcap' -C $(@D) dist/build/bustle-pcap
+endef
+
+define BUSTLE_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/dist/build/bustle-pcap \
+               $(TARGET_DIR)/usr/bin/bustle-pcap
+endef
+
+$(eval $(generic-package))