tpm2-abrmd: do not enforce -fstack-protector-all
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 15 Jan 2019 10:15:19 +0000 (11:15 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 16 Jan 2019 13:24:56 +0000 (14:24 +0100)
Stack protection is now controlled Buildroot wide with the BR2_SSP_*
options, so disable the explicit -fstack-protector-all so the SSP logic in
the toolchain wrapper is used instead.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tpm2-abrmd/tpm2-abrmd.mk

index 74cc66ba20201d7160283445e28b17bc467d6a9c..2834615ac3585d5daab92fc84382eac0fc7f8a31 100644 (file)
@@ -11,9 +11,10 @@ TPM2_ABRMD_LICENSE_FILES = LICENSE
 TPM2_ABRMD_INSTALL_STAGING = YES
 TPM2_ABRMD_DEPENDENCIES = dbus libglib2 tpm2-tss host-pkgconf
 
-# configure.ac doesn't contain a link test, so it doesn't detect when
-# libssp is missing.
-TPM2_ABRMD_CONF_ENV = ax_cv_check_cflags___________Werror_______fstack_protector_all=$(if $(BR2_TOOLCHAIN_HAS_SSP),yes,no)
+# -fstack-protector-all is used by default. Disable that so the
+# BR2_SSP_* options in the toolchain wrapper are used instead
+TPM2_ABRMD_CONF_ENV = \
+       ax_cv_check_cflags___________Werror_______fstack_protector_all=no
 
 TPM2_ABRMD_CONF_OPTS += \
        --with-systemdsystemunitdir=$(if $(BR2_INIT_SYSTEMD),/usr/lib/systemd/system,no) \