package/python-web2py: fix permissions
authorNoé Rubinstein <noe.rubinstein@gmail.com>
Wed, 4 Nov 2015 18:46:07 +0000 (19:46 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 4 Nov 2015 20:48:42 +0000 (21:48 +0100)
The PYTHON_WEB2PY_PERMISSIONS table was using the user and group names
instead of the uid and gid, causing makedevs to retrieve the uid and gid
from the host system.

Signed-off-by: Noé Rubinstein <nrubinstein@aldebaran.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/python-web2py/python-web2py.mk

index 313114ad69991d823c5aa8cb30df8628c08d38d5..db9ed8dfd8b96a668990baae9d2ed495a0925d2f 100644 (file)
@@ -32,8 +32,16 @@ define PYTHON_WEB2PY_INSTALL_INIT_SYSTEMD
                $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/web2py.service
 endef
 
+# www-data user and group are used for web2py. Because these user and group
+# are already set by buildroot, it is not necessary to redefine them.
+# See system/skeleton/etc/passwd
+#   username: www-data    uid: 33
+#   groupname: www-data   gid: 33
+#
+# So, we just need to create the directories used by web2py with the right
+# ownership.
 define PYTHON_WEB2PY_PERMISSIONS
-       /var/www/web2py  r  750  www-data  www-data  -  -  -  -  -
+       /var/www/web2py  r  750  33  33  -  -  -  -  -
 endef
 
 $(eval $(generic-package))