core/download: drop the SSH command
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 17 Nov 2018 17:15:48 +0000 (18:15 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 19 Nov 2018 21:11:31 +0000 (22:11 +0100)
The ssh command was added back in 2011 with commit c61788f09 (GENTARGETS:
add support for scp://) and was used to check that the remote file
existed, back when we supported 'make source-check'.

However, in 2017, with commit bf28a165d (pkg-{download, generic}: remove
source-check), we actually removed support for source-check.

The SSH command however was not removed then, and stuck, even though
nothing ever uses it It is not even exported in the environment, and scp
does not use it either (it has -S to specify an ssh-compatible program).

Get rid of it.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in
package/pkg-download.mk

index 03e4eb39287cc900541936b3c15156e76febeafd..f965e9d6d8e81142b712e94cd801f821773f37c0 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -136,10 +136,6 @@ config BR2_SCP
        string "Secure copy (scp) command"
        default "scp"
 
-config BR2_SSH
-       string "Secure shell (ssh) command"
-       default "ssh"
-
 config BR2_HG
        string "Mercurial (hg) command"
        default "hg"
index 73ea2a69f82989c5e96621fa4b977a6f300acf29..6293e2985b8fc7eafcb6b7ff9d906c678c96f914 100644 (file)
@@ -15,7 +15,6 @@ export BZR := $(call qstrip,$(BR2_BZR))
 export GIT := $(call qstrip,$(BR2_GIT))
 export HG := $(call qstrip,$(BR2_HG))
 export SCP := $(call qstrip,$(BR2_SCP))
-SSH := $(call qstrip,$(BR2_SSH))
 export LOCALFILES := $(call qstrip,$(BR2_LOCALFILES))
 
 DL_WRAPPER = support/download/dl-wrapper