libselinux: use $(TARGET_MAKE_ENV) when calling $(MAKE)
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>
Fri, 28 Oct 2016 13:18:22 +0000 (10:18 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Oct 2016 13:52:38 +0000 (15:52 +0200)
Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libselinux/libselinux.mk

index 6f9417321afe4ac2dddccc2db27ba393035e6aa1..29ed0efacf1b89d04c146d8a4ac985f13d100825 100644 (file)
@@ -23,15 +23,18 @@ LIBSELINUX_MAKE_OPTS = \
 define LIBSELINUX_BUILD_CMDS
        # DESTDIR is needed during the compile to compute library and
        # header paths.
-       $(MAKE) -C $(@D) $(LIBSELINUX_MAKE_OPTS) DESTDIR=$(STAGING_DIR) all
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+               $(LIBSELINUX_MAKE_OPTS) DESTDIR=$(STAGING_DIR) all
 endef
 
 define LIBSELINUX_INSTALL_STAGING_CMDS
-       $(MAKE) -C $(@D) $(LIBSELINUX_MAKE_OPTS) DESTDIR=$(STAGING_DIR) install
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+               $(LIBSELINUX_MAKE_OPTS) DESTDIR=$(STAGING_DIR) install
 endef
 
 define LIBSELINUX_INSTALL_TARGET_CMDS
-       $(MAKE) -C $(@D) $(LIBSELINUX_MAKE_OPTS) DESTDIR=$(TARGET_DIR) install
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+               $(LIBSELINUX_MAKE_OPTS) DESTDIR=$(TARGET_DIR) install
        # Create the selinuxfs mount point
        if [ ! -d "$(TARGET_DIR)/selinux" ]; then mkdir $(TARGET_DIR)/selinux; fi
        if ! grep -q "selinuxfs" $(TARGET_DIR)/etc/fstab; then \