package/libsvg-cairo: new package
authorCarsten Schoenert <c.schoenert@gmail.com>
Mon, 15 Jul 2013 19:52:38 +0000 (21:52 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 15 Jul 2013 21:11:04 +0000 (23:11 +0200)
Libsvg-cairo provides the ability to render SVG content from files or
buffers. All rendering is performed using the cairo rendering library.

[Peter: license is LGPLv2.1+]
Signed-off-by: Carsten Schoenert <c.schoenert@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/libsvg-cairo/Config.in [new file with mode: 0644]
package/libsvg-cairo/libsvg-cairo.mk [new file with mode: 0644]

index 6d5ff0130a1bbc01263e77c3858405eb94953561..aac31bf45b6d49fb8e5f95ee981db598119299bc 100644 (file)
@@ -465,6 +465,7 @@ source "package/libqrencode/Config.in"
 source "package/libraw/Config.in"
 source "package/librsvg/Config.in"
 source "package/libsvg/Config.in"
+source "package/libsvg-cairo/Config.in"
 source "package/libsvgtiny/Config.in"
 source "package/libungif/Config.in"
 source "package/opencv/Config.in"
diff --git a/package/libsvg-cairo/Config.in b/package/libsvg-cairo/Config.in
new file mode 100644 (file)
index 0000000..9577c69
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBSVG_CAIRO
+       bool "libsvg-cairo"
+       select BR2_PACKAGE_CAIRO
+       select BR2_PACKAGE_CAIRO_SVG
+       select BR2_PACKAGE_LIBSVG
+       help
+         Libsvg-cairo provides the ability to render SVG content from
+         files or buffers. All rendering is performed using the cairo
+         rendering library.
+
+         http://cairographics.org
diff --git a/package/libsvg-cairo/libsvg-cairo.mk b/package/libsvg-cairo/libsvg-cairo.mk
new file mode 100644 (file)
index 0000000..a168180
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# libsvg-cairo
+#
+################################################################################
+
+LIBSVG_CAIRO_VERSION         = 0.1.6
+LIBSVG_CAIRO_SITE            = http://cairographics.org/snapshots/
+LIBSVG_CAIRO_DEPENDENCIES    = cairo libsvg
+LIBSVG_CAIRO_INSTALL_STAGING = YES
+LIBSVG_CAIRO_LICENSE         = LGPLv2.1+
+LIBSVG_CAIRO_LICENSE_FILES   = COPYING
+
+$(eval $(autotools-package))