python-cheetah: add host-package support
authorGwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Fri, 13 Mar 2015 08:24:09 +0000 (09:24 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 13 Mar 2015 21:38:27 +0000 (22:38 +0100)
Some packages, like GNURadio for VOLK, needs cheetah on host at buildtime.

The dependency on host-python-markdown is needed to avoid that setuptools
downloads markdown if it is not installed yet.

[Thomas: add comment in the .mk file.]

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Reviewed-by: Samuel Martin <s.martin49@gmail.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/python-cheetah/python-cheetah.mk

index 08076b563d3e7efe1854287f14472b3ab2b11b87..7354190cf3feffabdd6cf3191938f4a2b3e450b9 100644 (file)
@@ -10,4 +10,9 @@ PYTHON_CHEETAH_SITE = http://pypi.python.org/packages/source/C/Cheetah
 PYTHON_CHEETAH_LICENSE = MIT
 PYTHON_CHEETAH_SETUP_TYPE = setuptools
 
+# The dependency on host-python-markdown is needed to prevent
+# setuptools from downloading markdown if it is not installed yet.
+HOST_PYTHON_CHEETAH_DEPENDENCIES = host-python-markdown
+
 $(eval $(python-package))
+$(eval $(host-python-package))