Cleanup of mplayer package
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Mon, 23 Jul 2007 12:40:43 +0000 (12:40 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Mon, 23 Jul 2007 12:40:43 +0000 (12:40 -0000)
package/mplayer/mplayer.mk

index 9fe42b35085c6184e4538139aa146b8d27fa52dc..3634600a6d819bf88809ea702bb4ae87677af87b 100644 (file)
@@ -3,10 +3,10 @@
 # mplayer
 #
 #############################################################
-MPLAYER_VER:=1.0rc1
-MPLAYER_SOURCE:=MPlayer-$(MPLAYER_VER).tar.bz2
+MPLAYER_VERSION:=1.0rc1
+MPLAYER_SOURCE:=MPlayer-$(MPLAYER_VERSION).tar.bz2
 MPLAYER_SITE:=http://www7.mplayerhq.hu/MPlayer/releases
-MPLAYER_DIR:=$(BUILD_DIR)/MPlayer-$(MPLAYER_VER)
+MPLAYER_DIR:=$(BUILD_DIR)/MPlayer-$(MPLAYER_VERSION)
 MPLAYER_CAT:=$(BZCAT)
 MPLAYER_BINARY:=mplayer
 MPLAYER_TARGET_BINARY:=usr/bin/$(MPLAYER_BINARY)
@@ -22,12 +22,13 @@ $(DL_DIR)/$(MPLAYER_SOURCE):
 
 $(MPLAYER_DIR)/.unpacked: $(DL_DIR)/$(MPLAYER_SOURCE)
        $(MPLAYER_CAT) $(DL_DIR)/$(MPLAYER_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       toolchain/patch-kernel.sh $(MPLAYER_DIR) package/mplayer/ mplayer-$(MPLAYER_VER)\*.patch\*
-       @touch $@
+       toolchain/patch-kernel.sh $(MPLAYER_DIR) package/mplayer/ mplayer-$(MPLAYER_VERSION)\*.patch\*
+       touch $@
 
 $(MPLAYER_DIR)/.configured: $(MPLAYER_DIR)/.unpacked
        (cd $(MPLAYER_DIR); rm -rf config.cache; \
                $(TARGET_CONFIGURE_OPTS) \
+               $(TARGET_CONFIGURE_ARGS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
                ./configure \
@@ -46,16 +47,16 @@ $(MPLAYER_DIR)/.configured: $(MPLAYER_DIR)/.unpacked
                --disable-tv \
                --enable-dynamic-plugins \
        );
-       @touch $@
+       touch $@
 
 $(MPLAYER_DIR)/$(MPLAYER_BINARY): $(MPLAYER_DIR)/.configured
        $(MAKE) -C $(MPLAYER_DIR)
-       @touch -c $@
+       touch -c $@
 
 $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY): $(MPLAYER_DIR)/$(MPLAYER_BINARY)
        $(INSTALL) -m 0755 -D $(MPLAYER_DIR)/$(MPLAYER_BINARY) $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY)
        -$(STRIP) --strip-unneeded $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY)
-       @touch -c $@
+       touch -c $@
 
 mplayer: uclibc libmad $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY)