projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3c69584
)
package/pkg-golang: add PATH in GO_TARGET_ENV
author
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Mon, 2 Apr 2018 13:41:45 +0000
(15:41 +0200)
committer
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Mon, 2 Apr 2018 15:23:36 +0000
(17:23 +0200)
Some Go packages use pkg-config to detect native libraries, so we must
have $(BR_PATH) in the PATH so that our pkg-config in HOST_DIR gets
used.
Fixes:
http://autobuild.buildroot.net/results/
f85414244c25aba07a05109b5cd7658ae44a64ea
/
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-golang.mk
patch
|
blob
|
history
diff --git
a/package/pkg-golang.mk
b/package/pkg-golang.mk
index f23bda390d4768816911c91e4a1eb78586224042..bf178622b50f39ea00dbbd156b0e2899267c41d2 100644
(file)
--- a/
package/pkg-golang.mk
+++ b/
package/pkg-golang.mk
@@
-27,6
+27,7
@@
GO_BIN = $(HOST_DIR)/bin/go
# cross-compiled binaries when GOBIN is set"
GO_TARGET_ENV = \
$(HOST_GO_TARGET_ENV) \
+ PATH=$(BR_PATH) \
GOBIN= \
CGO_ENABLED=$(HOST_GO_CGO_ENABLED)