package/vlc: disable for static-only builds
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 9 Jan 2016 21:13:36 +0000 (22:13 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 13 Jan 2016 21:16:41 +0000 (22:16 +0100)
vlc configure errors out for a non-shared build:
http://git.videolan.org/gitweb.cgi?p=vlc.git;a=blob;f=configure.ac;h=d44151b3fb507141ce7f9b98e95fa11edcdaac01;hb=HEAD#l450

Fixes
http://autobuild.buildroot.net/results/f93/f93771b4f76b82197b930e6fde5eb7aebfe9c910/
http://autobuild.buildroot.net/results/4af/4af880a8a8a37efd57e12e18d43183ba49f5cbe0/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/vlc/Config.in

index e2b8da9b5521fdc3c156767cf6cfaee3f26b718e..03e85c3fcaf0a0f721e6132980abc9791e8560d8 100644 (file)
@@ -7,6 +7,7 @@ config BR2_PACKAGE_VLC
        bool "vlc"
        depends on (BR2_UCLIBC_VERSION_SNAPSHOT || BR2_UCLIBC_VERSION_NG || BR2_TOOLCHAIN_USES_GLIBC) # spawn.h
        depends on BR2_INSTALL_LIBSTDCPP
+       depends on !BR2_STATIC_LIBS
        depends on BR2_USE_WCHAR
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_7
@@ -31,7 +32,7 @@ config BR2_PACKAGE_VLC_OPENCV3_BACKEND
        select BR2_PACKAGE_OPENCV3_LIB_IMGPROC
        select BR2_PACKAGE_OPENCV3_LIB_OBJDETECT
 
-comment "vlc needs a uclibc snapshot, uclibc-ng or (e)glibc toolchain w/ C++, wchar, threads, headers >= 3.7"
+comment "vlc needs a uclibc snapshot, uclibc-ng or (e)glibc toolchain w/ C++, dynamic library, wchar, threads, headers >= 3.7"
        depends on !(BR2_UCLIBC_VERSION_SNAPSHOT || BR2_UCLIBC_VERSION_NG || BR2_TOOLCHAIN_USES_GLIBC) \
-               || !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR \
+               || !BR2_INSTALL_LIBSTDCPP || BR2_STATIC_LIBS || !BR2_USE_WCHAR \
                || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_7