Allow to run severals post build scripts instead of only one
authorPhilippe Reynes <philippe.reynes@sagemcom.com>
Sat, 17 Nov 2012 12:01:22 +0000 (13:01 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 17 Nov 2012 16:23:59 +0000 (17:23 +0100)
Using severals post build scripts is usefull to share
script between severals boards/projects.

[Peter: fix trailing spaces in Config.in]
Signed-off-by: Philippe Reynes <philippe.reynes@sagemcom.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile
system/Config.in

index 3e7d520af57dfd83a19357ded44ab212510c606e..7602499555fab9b862365cb034d58f2619b44223 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -470,8 +470,9 @@ endif
        ) >  $(TARGET_DIR)/etc/os-release
 
 ifneq ($(BR2_ROOTFS_POST_BUILD_SCRIPT),"")
-       @$(call MESSAGE,"Executing post-build script")
-       $(BR2_ROOTFS_POST_BUILD_SCRIPT) $(TARGET_DIR)
+       @$(call MESSAGE,"Executing post-build script\(s\)")
+       @$(foreach s, $(call qstrip,$(BR2_ROOTFS_POST_BUILD_SCRIPT)), \
+               $(s) $(TARGET_DIR)$(sep))
 endif
 
 ifeq ($(BR2_ENABLE_LOCALE_PURGE),y)
index 10c9d9db3105e60c07f960f9bc6826b848602324..58232108e468897d016f39e4cd67676962825de0 100644 (file)
@@ -170,15 +170,16 @@ config BR2_ROOTFS_POST_BUILD_SCRIPT
        string "Custom script to run before creating filesystem images"
        default ""
        help
-         Specify a script to be run after the build has finished and before
-         Buildroot starts packing the files into selected filesystem images.
+         Specify a space-separated list of scripts to be run after the build
+         has finished and before Buildroot starts packing the files into
+         selected filesystem images.
 
          This gives users the oportunity to do board-specific cleanups,
          add-ons and the like, so the generated files can be used directly
          without further processing.
 
-         The script is called with the target directory name as first and
-         only argument. Make sure the exit code of that script is 0,
-         otherwise make will stop after calling it.
+         These scripts are called with the target directory name as first and
+         only argument. Make sure the exit code of those scripts are 0,
+         otherwise make will stop after calling them.
 
 endmenu