- store BR2_PACKAGE_LINUX_KCONFIG and BR2_PACKAGE_LINUX_FORMAT in .config
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 11 Apr 2007 08:21:55 +0000 (08:21 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 11 Apr 2007 08:21:55 +0000 (08:21 -0000)
- adjust a few defaults.

target/device/Config.in
target/device/x86/i386/Makefile.in
toolchain/gcc/Config.in
toolchain/kernel-headers/Config.in

index 15abad8f639f79adf8f6708dca8d019c548f043b..cbad6fd6ba09bdcc8affffd2fa46257f161fefce 100644 (file)
@@ -11,6 +11,36 @@ config BR2_PACKAGE_LINUX
                kernel headers are just that (headers) and not full
                kernels. This is a feature.
 
+config BR2_PACKAGE_LINUX_KCONFIG
+       string ".config file"
+       depends on BR2_PACKAGE_LINUX
+       default ""
+       help
+         kernel's .config to use to build a kernel for the target.
+
+         If the above setting is empty, you can change the default
+         board-imposed value by passing LINUX26_KCONFIG=<path> to
+         make.
+
+config BR2_PACKAGE_LINUX_FORMAT
+       string "kernel binary format"
+       depends on BR2_PACKAGE_LINUX
+       default ""
+       help
+         kernel binary format.
+         Popular values include:
+         - bzImage
+         - zImage
+         and other, architecture dependant formats.
+
+         Note that the default format is supposed to be set by your
+         board-description, if any.
+         i386 and compatible default to bzImage if nothing was given
+         above.
+         If the above setting is empty, you can change the default
+         board-imposed value by passing LINUX26_FORMAT=<string> to
+         make.
+
 source "target/device/AMD/Config.in"
 source "target/device/Arm/Config.in"
 source "target/device/Atmel/Config.in"
index 876304b7efe8d68b65655f80c0e430b7cea20c6c..08ae1b1a28655fd4a7e41b32401b87be6596647e 100644 (file)
@@ -1,7 +1,17 @@
 BR2_BOARD_PATH:=target/device/x86/i386
 
+ifeq ($(strip $(BR2_PACKAGE_LINUX_KCONFIG)),)
 ifndef LINUX26_KCONFIG
 LINUX26_KCONFIG=$(BR2_BOARD_PATH)/linux26.config
 endif
-LINUX26_FORMAT=bzImage
+else
+LINUX26_KCONFIG=$(strip $(BR2_PACKAGE_LINUX_KCONFIG))
+endif
 
+ifeq ($(strip $(BR2_PACKAGE_LINUX_FORMAT)),)
+ifndef LINUX26_FORMAT
+LINUX26_FORMAT=bzImage
+endif
+else
+LINUX26_FORMAT=$(strip $(BR2_PACKAGE_LINUX_FORMAT))
+endif
index f28a365aac2ca09b269c94c7dfe5eee9734eac9f..f834ed314a8d4a3a3f354882d1e79c77dd552ca2 100644 (file)
@@ -4,7 +4,7 @@ comment "Gcc Options"
 
 choice
        prompt "GCC compiler Version"
-       default BR2_GCC_VERSION_3_4_6
+       default BR2_GCC_VERSION_4_1_2
        help
          Select the version of gcc you wish to use.
 
index 8af18e10cb331637c4fe158277af980a8af1c99a..76e0858c1eece89bb39e7b786ec420b671b131b0 100644 (file)
@@ -6,7 +6,7 @@ comment "Kernel Header Options"
 
 choice
        prompt "Kernel Headers"
-       default BR2_KERNEL_HEADERS_2_4_31
+       default BR2_KERNEL_HEADERS_2_6_20
        help
          Select the version of kernel header files you wish to use.
          You must select the correct set of header files to match
@@ -25,7 +25,7 @@ choice
                bool "Linux 2.4.29 kernel headers"
 
        config BR2_KERNEL_HEADERS_2_4_31
-               depends !BR2_nios2
+               depends !BR2_nios2 && BR2_DEPRECATED
                bool "Linux 2.4.31 kernel headers"
 
        config BR2_KERNEL_HEADERS_2_6_9
@@ -37,7 +37,7 @@ choice
                bool "Linux 2.6.11 kernel headers"
 
        config BR2_KERNEL_HEADERS_2_6_12
-               depends !BR2_nios2
+               depends !BR2_nios2 && BR2_DEPRECATED
                bool "Linux 2.6.12 kernel headers"
 
        config BR2_KERNEL_HEADERS_2_6_19_2