coreutils: disable stdbuf for static builds
authorDavid du Colombier <0intro@gmail.com>
Sat, 28 Nov 2015 21:17:30 +0000 (22:17 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 17 Dec 2015 21:47:34 +0000 (22:47 +0100)
When stdbuf is enabled, it builds a shared library, but it will fail
in a static-only scenario.

Fixes:

  http://autobuild.buildroot.org/results/974/9741cc9841fa95f7430a91f585c4464ee2c9311b/

Signed-off-by: David du Colombier <0intro@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/coreutils/coreutils.mk

index 60455ace7a08fb60420ffea8d65780aa804b55cc..d8e2ee6198db142f54307dfad83f1de2c12bc62c 100644 (file)
@@ -109,6 +109,10 @@ endef
 COREUTILS_POST_INSTALL_TARGET_HOOKS += COREUTILS_CLEANUP_BIN
 endif
 
+ifeq ($(BR2_STATIC_LIBS),y)
+COREUTILS_CONF_OPTS += --enable-no-install-program=stdbuf
+endif
+
 define COREUTILS_CLEANUP
        # link for archaic shells
        ln -fs test $(TARGET_DIR)/usr/bin/[