binutils: apply post-patch hook on both the host and target builds
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 May 2013 13:01:01 +0000 (13:01 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 30 May 2013 19:48:00 +0000 (21:48 +0200)
When a Xtensa specific patch needs to be applied, it should be applied
both when doing the target and the host build.

This change is part of the effort to remove the differences between
host and target post-extract and post-patch hooks, that are
problematic for the out-of-tree support.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/binutils/binutils.mk

index 081be6ad4b38c8c8313af8c42277513b46a058d5..a2c4150c9bea0d1dd2fbdd6a8d73b9817c88057b 100644 (file)
@@ -81,6 +81,7 @@ define BINUTILS_XTENSA_PRE_PATCH
        tar xf $(BR2_XTENSA_OVERLAY_DIR)/xtensa_$(XTENSA_CORE_NAME).tar \
                -C $(@D) --strip-components=1 binutils
 endef
+BINUTILS_PRE_PATCH_HOOKS += BINUTILS_XTENSA_PRE_PATCH
 HOST_BINUTILS_PRE_PATCH_HOOKS += BINUTILS_XTENSA_PRE_PATCH
 endif