erlang-p1-sip: new package.
authorJohan Oudinet <johan.oudinet@gmail.com>
Mon, 12 Jan 2015 09:32:17 +0000 (10:32 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 3 Feb 2015 09:23:29 +0000 (10:23 +0100)
[Thomas: adjust license to be 'GPLv2 with OpenSSL exception' instead
of just 'GPLv2'.]

Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/erlang-p1-sip/Config.in [new file with mode: 0644]
package/erlang-p1-sip/erlang-p1-sip-01-fix-includes.patch [new file with mode: 0644]
package/erlang-p1-sip/erlang-p1-sip.mk [new file with mode: 0644]

index f66e24e0b422266fce87faedaecc27723b2342c7..bfe6aa72007f9499af9a1e5141db54569e9fec9b 100644 (file)
@@ -401,6 +401,7 @@ if BR2_PACKAGE_ERLANG
 menu "Erlang libraries/modules"
        source "package/erlang-goldrush/Config.in"
        source "package/erlang-lager/Config.in"
+       source "package/erlang-p1-sip/Config.in"
        source "package/erlang-p1-stringprep/Config.in"
        source "package/erlang-p1-stun/Config.in"
        source "package/erlang-p1-tls/Config.in"
diff --git a/package/erlang-p1-sip/Config.in b/package/erlang-p1-sip/Config.in
new file mode 100644 (file)
index 0000000..70cf819
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_ERLANG_P1_SIP
+       bool "erlang-p1-sip"
+       select BR2_PACKAGE_ERLANG_P1_STUN
+       select BR2_PACKAGE_ERLANG_P1_TLS
+       select BR2_PACKAGE_ERLANG_P1_UTILS
+       help
+         SIP library for Erlang
+
+         https://github.com/processone/p1_sip
diff --git a/package/erlang-p1-sip/erlang-p1-sip-01-fix-includes.patch b/package/erlang-p1-sip/erlang-p1-sip-01-fix-includes.patch
new file mode 100644 (file)
index 0000000..80e2ab3
--- /dev/null
@@ -0,0 +1,19 @@
+Description: correct include
+ This part of the code was moved into it's own project and was packaged
+ separately by me. To make the build process work, this small fix is
+ necessary.
+Author: Philipp Huebner <debalance@debian.org>
+
+Index: erlang-p1-sip/src/esip_socket.erl
+===================================================================
+--- erlang-p1-sip.orig/src/esip_socket.erl
++++ erlang-p1-sip/src/esip_socket.erl
+@@ -22,7 +22,7 @@
+ -include("esip.hrl").
+ -include("esip_lib.hrl").
+--include("stun.hrl").
++-include_lib("p1_stun/include/stun.hrl").
+ -define(TCP_SEND_TIMEOUT, 15000).
+ -define(CONNECT_TIMEOUT, 20000).
diff --git a/package/erlang-p1-sip/erlang-p1-sip.mk b/package/erlang-p1-sip/erlang-p1-sip.mk
new file mode 100644 (file)
index 0000000..b895f59
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# erlang-p1-sip
+#
+################################################################################
+
+ERLANG_P1_SIP_VERSION = bba4459
+ERLANG_P1_SIP_SITE = $(call github,processone,p1_sip,$(ERLANG_P1_SIP_VERSION))
+ERLANG_P1_SIP_LICENSE = GPLv2 with OpenSSL exception
+ERLANG_P1_SIP_LICENSE_FILES = COPYING
+ERLANG_P1_SIP_DEPENDENCIES = erlang-p1-stun erlang-p1-tls erlang-p1-utils
+ERLANG_P1_SIP_INSTALL_STAGING = YES
+
+$(eval $(rebar-package))