linux: Add dependency on host-module-init-tools
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 5 Jun 2010 19:26:18 +0000 (21:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 22 Jun 2010 19:20:27 +0000 (21:20 +0200)
In order to not depend on module init tools being installed on the
development environment of the Buildroot user, let's build module init
tools for the host.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux.mk
package/module-init-tools/module-init-tools.mk

index 3e91ecabaa200dc72d91890f216a02bb31e60bac..8b83e306611d5070ffe4c99504ceff0af3426aa3 100644 (file)
@@ -111,7 +111,7 @@ $(LINUX26_DIR)/.stamp_installed: $(LINUX26_DIR)/.stamp_compiled
        fi
        $(Q)touch $@
 
-linux26: $(LINUX26_DEPENDENCIES) $(LINUX26_DIR)/.stamp_installed
+linux26: host-module-init-tools $(LINUX26_DEPENDENCIES) $(LINUX26_DIR)/.stamp_installed
 
 ifeq ($(BR2_LINUX_KERNEL),y)
 TARGETS+=linux26
index 3e8b06bde290adaa1fc171ac3130bd1b91d37435..ea7c014dccd7cd6b233c5c6c15e1dda3ee3da0b1 100644 (file)
@@ -17,3 +17,5 @@ MODULE_INIT_TOOLS_AUTORECONF=YES
 HOST_MODULE_INIT_TOOLS_AUTORECONF=YES
 
 $(eval $(call AUTOTARGETS,package,module-init-tools))
+$(eval $(call AUTOTARGETS,package,module-init-tools,host))
+