pango: generate pango.modules at build time rather than run time
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 18 Mar 2009 22:39:09 +0000 (22:39 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 18 Mar 2009 22:39:09 +0000 (22:39 -0000)
Generate pango.modules using the host tools instead of setting up an init
script to do it at run time. Also apply patches to host build to get
identical pango.modules file.

package/pango/S25pango [deleted file]
package/pango/pango.mk

diff --git a/package/pango/S25pango b/package/pango/S25pango
deleted file mode 100644 (file)
index 69b2c1c..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-#! /bin/sh
-#
-# run pango-querymodules if needed
-
-FILE=/etc/pango/pango.modules
-
-case "$1" in
-    start|"")
-       if [ ! -f "$FILE" ] ; then
-           mkdir -p /etc/pango
-           /usr/bin/pango-querymodules > "$FILE"
-       fi
-       ;;
-    stop)
-       ;;
-    *)
-       echo "Usage: $0 {start|stop}" >&2
-       exit 1
-       ;;
-esac
index ce62f4305ae2cc212467273e27fe925515b9afd4..b94a9b581c49b48fe7e5cf46ce1bcbcaa47800e9 100644 (file)
@@ -57,7 +57,9 @@ PANGO_DEPENDENCIES = uclibc gettext libintl host-pkgconfig libglib2 $(XSERVER) c
 $(eval $(call AUTOTARGETS,package,pango))
 
 $(PANGO_HOOK_POST_INSTALL):
-       $(INSTALL) -m 755 package/pango/S25pango $(TARGET_DIR)/etc/init.d/
+       mkdir -p $(TARGET_DIR)/etc/pango
+       $(PANGO_HOST_BINARY) > $(TARGET_DIR)/etc/pango/pango.modules
+       $(SED) 's~$(HOST_DIR)~~g' $(TARGET_DIR)/etc/pango/pango.modules
        touch $@
 
 # pango for the host
@@ -68,6 +70,7 @@ $(PANGO_HOST_DIR)/.unpacked: $(DL_DIR)/$(PANGO_SOURCE)
        mkdir -p $(@D)
        $(INFLATE$(suffix $(PANGO_SOURCE))) $< | \
                $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
+       toolchain/patch-kernel.sh $(@D) package/pango/ \*.patch
        touch $@
 
 $(PANGO_HOST_DIR)/.configured: $(PANGO_HOST_DIR)/.unpacked $(PKGCONFIG_HOST_BINARY) $(CAIRO_HOST_BINARY) $(LIBGLIB2_HOST_BINARY)