kodi: switch smb support to samba4
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 6 Mar 2015 12:50:31 +0000 (09:50 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Apr 2015 12:31:15 +0000 (14:31 +0200)
samba3 is deprecated upstream.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi/Config.in
package/kodi/kodi.mk

index 1f98267f482e7584dbb980b4710acb5b0e34cfa5..a0cbb18660c377e5e84ebdc24940d2dfeccbadb9 100644 (file)
@@ -202,10 +202,13 @@ config BR2_PACKAGE_KODI_LIBSHAIRPLAY
 comment "shairport support needs a toolchain w/ dynamic library"
        depends on BR2_STATIC_LIBS
 
+comment "samba support needs an (e)glibc toolchain"
+       depends on !BR2_TOOLCHAIN_USES_GLIBC
+
 config BR2_PACKAGE_KODI_LIBSMBCLIENT
        bool "samba"
-       select BR2_PACKAGE_SAMBA
-       select BR2_PACKAGE_SAMBA_LIBSMBCLIENT
+       depends on BR2_TOOLCHAIN_USES_GLIBC
+       select BR2_PACKAGE_SAMBA4
        help
          Enable Samba support
 
index ca8563dd107ad23557b82d28128bb52c034c2770..ad73dcbc118a89547bffdf046ab9e239ad82dfb6 100644 (file)
@@ -140,7 +140,7 @@ KODI_CONF_OPTS += --disable-webserver
 endif
 
 ifeq ($(BR2_PACKAGE_KODI_LIBSMBCLIENT),y)
-KODI_DEPENDENCIES += samba
+KODI_DEPENDENCIES += samba4
 KODI_CONF_OPTS += --enable-samba
 else
 KODI_CONF_OPTS += --disable-samba