prboom: bump version
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 14 Oct 2010 18:08:29 +0000 (20:08 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 14 Oct 2010 18:13:54 +0000 (20:13 +0200)
Special big endian handling is no longer needed and X option is gone.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/games/prboom/prboom.mk

index 228c78886de1146a34301c4968efd2a9a3828e1d..651118cab00819f3e4a46453d6b6bf56f8d6e902 100644 (file)
@@ -3,7 +3,8 @@
 # PrBoom
 #
 #############################################################
-PRBOOM_VERSION = 2.4.7
+PRBOOM_VERSION = 2.5.0
+PRBOOM_CONF_ENV = ac_cv_type_uid_t=yes
 PRBOOM_DEPENDENCIES = sdl SDL_net sdl_mixer
 
 PRBOOM_CONF_OPT = \
@@ -12,16 +13,7 @@ PRBOOM_CONF_OPT = \
                --with-sdl-exec-prefix=$(STAGING_DIR)/usr \
                --disable-cpu-opt \
                --disable-sdltest \
-               --disable-gl \
-               --without-x
-
-define PRBOOM_BIG_ENDIAN_FIXUP
-       $(SED) 's,.*#undef WORDS_BIGENDIAN.*,#define WORDS_BIGENDIAN 1,g' $(PRBOOM_DIR)/config.h
-endef
-
-ifeq ($(BR2_ENDIAN),"BIG")
-PRBOOM_POST_CONFIGURE_HOOKS += PRBOOM_BIG_ENDIAN_FIXUP
-endif
+               --disable-gl
 
 define PRBOOM_INSTALL_TARGET_CMDS
        $(INSTALL) -D $(@D)/src/prboom $(TARGET_DIR)/usr/games/prboom