aiccu: install init script and config file unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:40 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:15:23 +0000 (00:15 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/aiccu/aiccu.mk

index 4413f86fb85bd40a4b0c77762ccc22a687010655..faa861cf37cf140415b5d001b54fdfd688793c8e 100644 (file)
@@ -28,14 +28,12 @@ endef
 define AICCU_INSTALL_TARGET_CMDS
        $(INSTALL) -D -m 0755 $(@D)/unix-console/aiccu \
                $(TARGET_DIR)/usr/sbin/aiccu
-       [ -f $(TARGET_DIR)/etc/aiccu.conf ] || \
-               $(INSTALL) -D -m 0644 $(@D)/doc/aiccu.conf \
+       $(INSTALL) -D -m 0644 $(@D)/doc/aiccu.conf \
                $(TARGET_DIR)/etc/aiccu.conf
 endef
 
 define AICCU_INSTALL_INIT_SYSV
-       [ -f $(TARGET_DIR)/etc/init.d/S50aiccu ] || \
-               $(INSTALL) -D -m 0755 $(@D)/doc/aiccu.init \
+       $(INSTALL) -D -m 0755 $(@D)/doc/aiccu.init \
                $(TARGET_DIR)/etc/init.d/S50aiccu
 endef