package/Makefile.in: correct gettext handling for musl
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Feb 2016 16:02:06 +0000 (17:02 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Feb 2016 16:02:06 +0000 (17:02 +0100)
Based on a patch by Bernd Kuhls.

The AM_GNU_GETTEXT autotools macro misdetects musl gettext support as it
checks for internal glibc symbols.  Work around it by forcing libc gettext
support when musl is used for the supported gettext api levels.

As this is a generic issue for any package using AM_GNU_GETTEXT, add it to
the global TARGET_CONFIGURE_ARGS instead of for each affected package.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Makefile.in

index c5652af0f7e786d932a3c4094a5ee3ebb7ddb7a7..96d93b07a9d5ef7406b299ef5c0e3a544392178b 100644 (file)
@@ -340,6 +340,15 @@ else
 BR2_AC_CV_C_BIGENDIAN = ac_cv_c_bigendian=no
 endif
 
+# AM_GNU_GETTEXT misdetects musl gettext support.
+# musl currently implements api level 1 and 2 (basic + ngettext)
+# http://www.openwall.com/lists/musl/2015/04/16/3
+ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
+BR2_GT_CV_FUNC_GNUGETTEXT_LIBC = \
+       gt_cv_func_gnugettext1_libc=yes
+       gt_cv_func_gnugettext2_libc=yes
+endif
+
 TARGET_CONFIGURE_ARGS = \
        $(BR2_AC_CV_TRAP_CHECK) \
        ac_cv_func_mmap_fixed_mapped=yes \
@@ -350,7 +359,8 @@ TARGET_CONFIGURE_ARGS = \
        ac_cv_func_calloc_0_nonnull=yes \
        ac_cv_func_realloc_0_nonnull=yes \
        lt_cv_sys_lib_search_path_spec="" \
-       $(BR2_AC_CV_C_BIGENDIAN)
+       $(BR2_AC_CV_C_BIGENDIAN) \
+       $(BR2_GT_CV_FUNC_GNUGETTEXT_LIBC)
 
 ################################################################################