json-glib: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:49:51 +0000 (22:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:27:26 +0000 (01:27 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/json-glib/Config.in
package/json-glib/json-glib.mk

index ea15295b382508b3809a0000373ccc101edcf054..9df03d924abfbd0429dcf4e4442dc48007bfec32 100644 (file)
@@ -4,7 +4,6 @@ config BR2_PACKAGE_JSON_GLIB
        depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
        depends on BR2_USE_MMU # glib2
        select BR2_PACKAGE_LIBGLIB2
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
        help
          JSON-GLib is a library providing serialization and
          deserialization support for the JavaScript Object Notation
index db22dc9a78e33552d21fe97679ace0ac132b54ca..5ee43d9a123171749d8c26ea7312ac91b341e7b3 100644 (file)
@@ -13,7 +13,7 @@ JSON_GLIB_LICENSE_FILES = COPYING
 JSON_GLIB_INSTALL_STAGING = YES
 
 JSON_GLIB_DEPENDENCIES = \
-       $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) \
+       $(TARGET_NLS_DEPENDENCIES) \
        host-pkgconf \
        libglib2