libsoup: bump to version 2.43.1
authorSpenser Gilliland <spenser@gillilanding.com>
Fri, 7 Jun 2013 13:18:49 +0000 (13:18 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 8 Jun 2013 20:52:01 +0000 (22:52 +0200)
Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libsoup/Config.in
package/libsoup/libsoup.mk

index 57b425f283aaefb9975391cdb7d1338062118615..2ed08d933563333047815839611f5898bd1b4da7 100644 (file)
@@ -4,6 +4,7 @@ config BR2_PACKAGE_LIBSOUP
        select BR2_PACKAGE_LIBXML2
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
+       select BR2_PACKAGE_SQLITE
        help
          libsoup is an HTTP client/server library. It uses GObject
          and the GLib main loop, to integrate well with GNOME
index 2f7233aef1339af782d64a3db8c9bb02b8b70415..c9d90e83bff7ab0341da6edc785f4a2fa3df7f4a 100644 (file)
@@ -4,10 +4,10 @@
 #
 ################################################################################
 
-LIBSOUP_MAJOR_VERSION = 2.36
+LIBSOUP_MAJOR_VERSION = 2.43
 LIBSOUP_MINOR_VERSION = 1
 LIBSOUP_VERSION = $(LIBSOUP_MAJOR_VERSION).$(LIBSOUP_MINOR_VERSION)
-LIBSOUP_SOURCE = libsoup-$(LIBSOUP_VERSION).tar.bz2
+LIBSOUP_SOURCE = libsoup-$(LIBSOUP_VERSION).tar.xz
 LIBSOUP_SITE = http://ftp.gnome.org/pub/gnome/sources/libsoup/$(LIBSOUP_MAJOR_VERSION)
 LIBSOUP_INSTALL_STAGING = YES
 
@@ -19,7 +19,7 @@ endif
 
 LIBSOUP_CONF_OPT = --disable-glibtest --without-gnome
 
-LIBSOUP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) host-pkgconf host-libglib2 libglib2 libxml2
+LIBSOUP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) host-pkgconf host-libglib2 libglib2 libxml2 sqlite
 
 ifeq ($(BR2_PACKAGE_LIBSOUP_SSL),y)
 LIBSOUP_DEPENDENCIES += glib-networking