package/vlc: add optional dependency to x264
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:15 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 09:59:42 +0000 (11:59 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index 5e5230edc9e698799095b50a27e245f7bb0a13fc..bc20e2946ee69168d8dc8c22eb6d96afbf4109cc 100644 (file)
@@ -409,6 +409,13 @@ else
 VLC_CONF_OPTS += --disable-udev
 endif
 
+ifeq ($(BR2_PACKAGE_X264),y)
+VLC_CONF_OPTS += --enable-x264
+VLC_DEPENDENCIES += x264
+else
+VLC_CONF_OPTS += --disable-x264
+endif
+
 ifeq ($(BR2_PACKAGE_XCB_UTIL_KEYSYMS),y)
 VLC_CONF_OPTS += --enable-xcb
 VLC_DEPENDENCIES += xcb-util-keysyms