package/sdl_mixer: prefer tremor over libvorbis
authorPaul Cercueil <paul@crapouillou.net>
Thu, 12 Dec 2019 17:18:59 +0000 (18:18 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 12 Dec 2019 20:53:07 +0000 (21:53 +0100)
When Tremor is enabled, configure SDL_mixer to use this Vorbis decoding
library instead of libvorbis. Since Tremor does fixed-point math, it is
safe to assume that if it's enabled then it is faster than libvorbis on
the target architecture.

Signed-off-by: Paul Cercueil <paul@crapouillou.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/sdl_mixer/sdl_mixer.mk

index 81ace864985f6ae9d03e4452a33a248f9aebdb98..0423817316551b2f32764c090a57c51f17fd5400 100644 (file)
@@ -42,7 +42,10 @@ else
 SDL_MIXER_CONF_OPTS += --disable-music-mod-modplug
 endif
 
-ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
+ifeq ($(BR2_PACKAGE_TREMOR),y)
+SDL_MIXER_CONF_OPTS += --enable-music-ogg-tremor
+SDL_MIXER_DEPENDENCIES += tremor
+else ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
 SDL_MIXER_CONF_OPTS += --enable-music-ogg
 SDL_MIXER_DEPENDENCIES += libvorbis
 else