pciutils: fix build with external toolchains
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Aug 2009 22:34:47 +0000 (00:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Aug 2009 22:36:47 +0000 (00:36 +0200)
Buildroot Makefile to compile pciutils wasn't passing TARGET_LDFLAGS
to pciutils build system. Therefore, at link time, the pciutils build
system was not taking into account the important --sysroot option,
which was breaking the link with external toolchains.

Fixes bug #523.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
CHANGES
package/pciutils/pciutils.mk

diff --git a/CHANGES b/CHANGES
index 527383c9d988a534f57783b60a8f3d34337e0832..684b3946c58a3ec41d92bf718079f23ef90dbe97 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -50,6 +50,7 @@
        #495: Bump bind package to 9.5.1-P3 (security)
        #497: OpenSSL RSA key generation hangs on x86_64
        #509: Bump sqlite package to 3.6.16
+       #527: pciutils broken with external toolchain
 
 2009.05, Released June 1st, 2009:
 
index 0d8155f4078033722cf6119a462a015b0f023a2a..976afbf177146598fd819573005ab809abc0cae3 100644 (file)
@@ -41,7 +41,7 @@ $(PCIUTILS_DIR)/.unpacked: $(DL_DIR)/$(PCIUTILS_SOURCE) $(DL_DIR)/$(PCIIDS_SOURC
        touch $@
 
 $(PCIUTILS_DIR)/.compiled: $(PCIUTILS_DIR)/.unpacked
-       $(MAKE1) CC="$(TARGET_CC)" OPT="$(TARGET_CFLAGS)" RANLIB=$(TARGET_RANLIB) AR=$(TARGET_AR) -C $(PCIUTILS_DIR) \
+       $(MAKE1) CC="$(TARGET_CC)" OPT="$(TARGET_CFLAGS)" LDFLAGS="$(TARGET_LDFLAGS)" RANLIB=$(TARGET_RANLIB) AR=$(TARGET_AR) -C $(PCIUTILS_DIR) \
                SHAREDIR="/usr/share/misc" \
                ZLIB=$(PCIUTILS_HAVE_ZLIB) \
                HOST=$(KERNEL_ARCH)-linux \