gnutls: fix libz autodetection failure
authorAntoine Pierlot-Garcin <antoine@bokbox.com>
Tue, 4 Feb 2014 14:57:43 +0000 (15:57 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 4 Feb 2014 17:09:14 +0000 (18:09 +0100)
The configure script finds libz in the distribution libraries, which causes
zlib support to be dropped from the cross-compiled GnuTLS.

Signed-off-by: Antoine Pierlot-Garcin <antoine@bokbox.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gnutls/gnutls.mk

index 73b525d70f254d8029b5464cc6da4584540d85fc..c0bd778264e1e8bb3557b29237c70608480fc0c0 100644 (file)
@@ -28,8 +28,9 @@ GNUTLS_CONF_ENV = gl_cv_socket_ipv6=$(if $(BR2_INET_IPV6),yes,no) \
        gl_cv_func_gettimeofday_clobber=no
 GNUTLS_INSTALL_STAGING = YES
 
-# libpthread autodetection poisons the linkpath
+# libpthread and libz autodetection poison the linkpath
 GNUTLS_CONF_OPT += $(if $(BR2_TOOLCHAIN_HAS_THREADS),--with-libpthread-prefix=$(STAGING_DIR)/usr)
+GNUTLS_CONF_OPT += $(if $(BR2_PACKAGE_ZLIB),--with-libz-prefix=$(STAGING_DIR)/usr)
 
 # gnutls needs libregex, but pcre can be used too
 # The check isn't cross-compile friendly