package/x11r7/libxcb: force the use of python2
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 25 Jun 2016 22:43:35 +0000 (00:43 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Jun 2016 12:57:48 +0000 (14:57 +0200)
libxcb in its current state is not python3-compatible:
https://bugs.freedesktop.org/show_bug.cgi?id=96395

Fixes
http://autobuild.buildroot.net/results/c74/c74fa243bf319472dca66982323df6c2a983642b/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/x11r7/libxcb/libxcb.mk

index a740638effcf9bfb5dd3f840b87b9a5a42e2f448..7f7823bf5303c67413428d66ab829c3d6aed7329 100644 (file)
@@ -19,5 +19,9 @@ LIBXCB_DEPENDENCIES = \
 LIBXCB_CONF_OPTS = --with-doxygen=no
 HOST_LIBXCB_CONF_OPTS = --with-doxygen=no
 
+# libxcb is not python3 friendly, so force the python interpreter
+HOST_LIBXCB_CONF_OPTS += ac_cv_path_PYTHON=$(HOST_DIR)/usr/bin/python2
+LIBXCB_CONF_OPTS += ac_cv_path_PYTHON=$(HOST_DIR)/usr/bin/python2
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))