package/mesa3d: Bump version to 10.4.0
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 14 Dec 2014 17:29:55 +0000 (18:29 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 14 Dec 2014 20:37:56 +0000 (21:37 +0100)
- removed mesa3d-0002-execinfo_h.patch, applied upstream
- renamed remaining patch according to new convention

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mesa3d/0001-Fix-khrplatform.h-not-installed-if-EGL-is-disabled.patch [new file with mode: 0644]
package/mesa3d/mesa3d-0001-Fix-khrplatform.h-not-installed-if-EGL-is-disabled.patch [deleted file]
package/mesa3d/mesa3d-0002-execinfo_h.patch [deleted file]
package/mesa3d/mesa3d.hash
package/mesa3d/mesa3d.mk

diff --git a/package/mesa3d/0001-Fix-khrplatform.h-not-installed-if-EGL-is-disabled.patch b/package/mesa3d/0001-Fix-khrplatform.h-not-installed-if-EGL-is-disabled.patch
new file mode 100644 (file)
index 0000000..5dc9099
--- /dev/null
@@ -0,0 +1,39 @@
+From 83a1afd73f2d0aff9aa11c1754d6d407983afa7d Mon Sep 17 00:00:00 2001
+From: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+Date: Wed, 9 Apr 2014 12:48:36 +0200
+Subject: [PATCH] Fix khrplatform.h not installed if EGL is disabled.
+
+KHR/khrplatform.h is required by the EGL, GLES and VG headers, but is
+only installed if Mesa3d is compiled with EGL support.
+
+This patch installs this header file unconditionally.
+
+Patch sent upstream: https://bugs.freedesktop.org/show_bug.cgi?id=77240
+
+Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> (rebased for mesa3d 10.3)
+
+diff -uNr Mesa-10.3.0-rc2.org/src/egl/main/Makefile.am Mesa-10.3.0-rc2/src/egl/main/Makefile.am
+--- Mesa-10.3.0-rc2.org/src/egl/main/Makefile.am       2014-08-29 00:00:57.000000000 +0200
++++ Mesa-10.3.0-rc2/src/egl/main/Makefile.am   2014-09-02 21:35:52.548071820 +0200
+@@ -85,9 +85,6 @@
+ pkgconfig_DATA = egl.pc
+-khrdir = $(includedir)/KHR
+-khr_HEADERS = $(top_srcdir)/include/KHR/khrplatform.h
+-
+ egldir = $(includedir)/EGL
+ egl_HEADERS = \
+       $(top_srcdir)/include/EGL/eglext.h \
+diff -uNr Mesa-10.3.0-rc2.org/src/mapi/Makefile.am Mesa-10.3.0-rc2/src/mapi/Makefile.am
+--- Mesa-10.3.0-rc2.org/src/mapi/Makefile.am   2014-09-01 01:22:12.000000000 +0200
++++ Mesa-10.3.0-rc2/src/mapi/Makefile.am       2014-09-02 21:36:22.891686861 +0200
+@@ -211,4 +211,7 @@
+ SUBDIRS += vgapi
+ endif
++khrdir = $(includedir)/KHR
++khr_HEADERS = $(top_srcdir)/include/KHR/khrplatform.h
++
+ include $(top_srcdir)/install-lib-links.mk
diff --git a/package/mesa3d/mesa3d-0001-Fix-khrplatform.h-not-installed-if-EGL-is-disabled.patch b/package/mesa3d/mesa3d-0001-Fix-khrplatform.h-not-installed-if-EGL-is-disabled.patch
deleted file mode 100644 (file)
index 5dc9099..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-From 83a1afd73f2d0aff9aa11c1754d6d407983afa7d Mon Sep 17 00:00:00 2001
-From: Eric Le Bihan <eric.le.bihan.dev@free.fr>
-Date: Wed, 9 Apr 2014 12:48:36 +0200
-Subject: [PATCH] Fix khrplatform.h not installed if EGL is disabled.
-
-KHR/khrplatform.h is required by the EGL, GLES and VG headers, but is
-only installed if Mesa3d is compiled with EGL support.
-
-This patch installs this header file unconditionally.
-
-Patch sent upstream: https://bugs.freedesktop.org/show_bug.cgi?id=77240
-
-Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> (rebased for mesa3d 10.3)
-
-diff -uNr Mesa-10.3.0-rc2.org/src/egl/main/Makefile.am Mesa-10.3.0-rc2/src/egl/main/Makefile.am
---- Mesa-10.3.0-rc2.org/src/egl/main/Makefile.am       2014-08-29 00:00:57.000000000 +0200
-+++ Mesa-10.3.0-rc2/src/egl/main/Makefile.am   2014-09-02 21:35:52.548071820 +0200
-@@ -85,9 +85,6 @@
- pkgconfig_DATA = egl.pc
--khrdir = $(includedir)/KHR
--khr_HEADERS = $(top_srcdir)/include/KHR/khrplatform.h
--
- egldir = $(includedir)/EGL
- egl_HEADERS = \
-       $(top_srcdir)/include/EGL/eglext.h \
-diff -uNr Mesa-10.3.0-rc2.org/src/mapi/Makefile.am Mesa-10.3.0-rc2/src/mapi/Makefile.am
---- Mesa-10.3.0-rc2.org/src/mapi/Makefile.am   2014-09-01 01:22:12.000000000 +0200
-+++ Mesa-10.3.0-rc2/src/mapi/Makefile.am       2014-09-02 21:36:22.891686861 +0200
-@@ -211,4 +211,7 @@
- SUBDIRS += vgapi
- endif
-+khrdir = $(includedir)/KHR
-+khr_HEADERS = $(top_srcdir)/include/KHR/khrplatform.h
-+
- include $(top_srcdir)/install-lib-links.mk
diff --git a/package/mesa3d/mesa3d-0002-execinfo_h.patch b/package/mesa3d/mesa3d-0002-execinfo_h.patch
deleted file mode 100644 (file)
index dbedfd1..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-Fixes uclibc build as uclibc does not include backtrace functionality
-
-Patch sent upstream:
-http://lists.freedesktop.org/archives/mesa-dev/2014-October/069506.html
-
-Bugtracker: https://bugs.freedesktop.org/show_bug.cgi?id=85197
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
-
-diff -uNr Mesa-10.3.1.org/configure.ac Mesa-10.3.1/configure.ac
---- Mesa-10.3.1.org/configure.ac       2014-10-12 22:42:38.000000000 +0200
-+++ Mesa-10.3.1/configure.ac   2014-10-19 19:15:11.000000000 +0200
-@@ -539,6 +539,9 @@
- dnl See if posix_memalign is available
- AC_CHECK_FUNC([posix_memalign], [DEFINES="$DEFINES -DHAVE_POSIX_MEMALIGN"])
-+dnl Check for backtrace support
-+AC_CHECK_HEADER([execinfo.h], [DEFINES="$DEFINES -DHAVE_EXECINFO_H"])
-+
- dnl Check for pthreads
- case "$host_os" in
- mingw*)
-diff -uNr Mesa-10.3.1.org/src/mapi/glapi/gen/gl_gentable.py Mesa-10.3.1/src/mapi/glapi/gen/gl_gentable.py
---- Mesa-10.3.1.org/src/mapi/glapi/gen/gl_gentable.py  2014-10-12 22:42:39.000000000 +0200
-+++ Mesa-10.3.1/src/mapi/glapi/gen/gl_gentable.py      2014-10-19 19:21:32.913846414 +0200
-@@ -42,7 +42,7 @@
- #endif
- #if (defined(GLXEXT) && defined(HAVE_BACKTRACE)) \\
--      || (!defined(GLXEXT) && defined(DEBUG) && !defined(_WIN32_WCE) && !defined(__CYGWIN__) && !defined(__MINGW32__) && !defined(__OpenBSD__) && !defined(__NetBSD__) && !defined(__DragonFly__))
-+      || (!defined(GLXEXT) && defined(DEBUG) && defined(HAVE_EXECINFO_H) && !defined(_WIN32_WCE) && !defined(__CYGWIN__) && !defined(__MINGW32__) && !defined(__OpenBSD__) && !defined(__NetBSD__) && !defined(__DragonFly__))
- #define USE_BACKTRACE
- #endif
-diff -uNr Mesa-10.3.1.org/src/mesa/drivers/dri/i915/intel_regions.c Mesa-10.3.1/src/mesa/drivers/dri/i915/intel_regions.c
---- Mesa-10.3.1.org/src/mesa/drivers/dri/i915/intel_regions.c  2014-05-06 00:45:23.000000000 +0200
-+++ Mesa-10.3.1/src/mesa/drivers/dri/i915/intel_regions.c      2014-10-19 19:23:13.833850693 +0200
-@@ -65,7 +65,9 @@
- #define _DBG(...) {debug_backtrace(); DBG(__VA_ARGS__);}
- /* Backtracing debug support */
-+#ifdef HAVE_EXECINFO_H
- #include <execinfo.h>
-+#endif
- static void
- debug_backtrace(void)
index bdcccaa6d00d54704a3d4c12c6b2a67f62c1f052..4c672055401ffb47470fb6f6e46a7e8ce5e88943 100644 (file)
@@ -1,2 +1,2 @@
-# From http://lists.freedesktop.org/archives/mesa-announce/2014-November/000122.html
-sha256 0e4eee4a2ddf86456eed2fc44da367f95471f74249636710491e85cc256c4753        MesaLib-10.3.3.tar.bz2
+# From http://lists.freedesktop.org/archives/mesa-announce/2014-December/000130.html
+sha256 98a7dff3a1a6708c79789de8b9a05d8042e867067f70e8f30387c15026233219        MesaLib-10.4.0.tar.bz2
index b3194d0902576ce20ab8c3afead9921c82fe12b7..1e39b82ebd870304716ecd166c39fba786b36ed1 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-MESA3D_VERSION = 10.3.5
+MESA3D_VERSION = 10.4.0
 MESA3D_SOURCE = MesaLib-$(MESA3D_VERSION).tar.bz2
 MESA3D_SITE = ftp://ftp.freedesktop.org/pub/mesa/$(MESA3D_VERSION)
 MESA3D_LICENSE = MIT, SGI, Khronos