bzip2: ensure target directories exist before copying into
authorLionel Landwerlin <llandwerlin@gmail.com>
Thu, 9 Dec 2010 09:55:13 +0000 (10:55 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 12 Dec 2010 23:40:54 +0000 (00:40 +0100)
Also simply installation rules a little

[Peter: leave in busybox install fix]
Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/bzip2/bzip2.mk

diff --git a/CHANGES b/CHANGES
index ac5b8cf453c47132f775a161c49d229820d21606..1179ac5496392abebbb0b37b0d15f431a65b5892 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -3,7 +3,7 @@
        Ccache support reworked. Now used for both host and target
        compilation, and cache is stored in ~/.buildroot-ccache.
 
-       Updated/fixed packages: at, busybox, dbus, cloop, cups,
+       Updated/fixed packages: at, busybox, bzip2, dbus, cloop, cups,
        gdk-pixbuf, hostapd, i2c-tools, libconfig, m4, openssh,
        openssl, pango, qt, rsync, sdl_gfx, sdl_sound, udev, usbutils,
        xz, zlib
index 3f341ee7a81e4c4798bff6e8863f49fe00f50748..123e579fc24bb7e19ecbde7c736b8b2f526a0ea3 100644 (file)
@@ -39,7 +39,9 @@ define BZIP2_BUILD_CMDS
 endef
 
 define BZIP2_INSTALL_STAGING_CMDS
-       cp $(@D)/bzlib.h $(STAGING_DIR)/usr/include/
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) \
+       $(MAKE) PREFIX=$(STAGING_DIR)/usr -C $(@D) install
+       $(INSTALL) -m 0755 -d $(STAGING_DIR)/usr/lib
        cp $(@D)/libbz2.so.$(BZIP2_SONAME) $(STAGING_DIR)/usr/lib/
        cp $(@D)/libbz2.a $(STAGING_DIR)/usr/lib/
        (cd $(STAGING_DIR)/usr/lib/; \