linux: Support multiple device tree build
authorMaxime Ripard <maxime.ripard@free-electrons.com>
Wed, 19 Dec 2012 22:48:09 +0000 (22:48 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 20 Dec 2012 14:25:10 +0000 (15:25 +0100)
Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/Config.in
linux/linux.mk

index 910d9a5241390e45806cafe02164feead1014c24..9ebe0c963295d555f4e3c33db4c63872963e33b1 100644 (file)
@@ -261,11 +261,12 @@ config BR2_LINUX_KERNEL_USE_CUSTOM_DTS
 endchoice
 
 config BR2_LINUX_KERNEL_INTREE_DTS_NAME
-       string "Device Tree Source file name"
+       string "Device Tree Source file names"
        depends on BR2_LINUX_KERNEL_USE_INTREE_DTS
        help
         Name of the device tree source file, without
-        the trailing .dts
+        the trailing .dts. You can provide a list of
+        dts files to build, separated by spaces.
 
 config BR2_LINUX_KERNEL_CUSTOM_DTS_PATH
        string "Device Tree Source file path"
index c4bdf90905d6a5f6804c58eb768646f0ef774ac3..3321d809a16b9ee61f3424d83495403abd75c1d7 100644 (file)
@@ -187,10 +187,13 @@ endef
 ifeq ($(BR2_LINUX_KERNEL_DTS_SUPPORT),y)
 ifeq ($(BR2_LINUX_KERNEL_DTB_IS_SELF_BUILT),)
 define LINUX_BUILD_DTB
-       $(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) $(KERNEL_DTS_NAME).dtb
+       $(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) \
+               $(addsuffix .dtb, $(call qstrip, $(KERNEL_DTS_NAME)))
 endef
 define LINUX_INSTALL_DTB
-       cp $(KERNEL_ARCH_PATH)/boot/$(KERNEL_DTS_NAME).dtb $(BINARIES_DIR)/
+       cp $(addprefix $(KERNEL_ARCH_PATH)/boot/, \
+               $(addsuffix .dtb, $(call qstrip, $(KERNEL_DTS_NAME)))) \
+               $(BINARIES_DIR)/
 endef
 endif
 endif