package/guile: rename patch to new convention
authorSamuel Martin <s.martin49@gmail.com>
Sat, 13 Dec 2014 17:43:07 +0000 (18:43 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Dec 2014 22:11:14 +0000 (23:11 +0100)
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/guile/0001-fix_arm_endianness.patch [new file with mode: 0644]
package/guile/0002-calculate-csqrt_manually.patch [new file with mode: 0644]
package/guile/0003-remove_unused_funcs.patch [new file with mode: 0644]
package/guile/guile-01-fix_arm_endianness.patch [deleted file]
package/guile/guile-02-calculate-csqrt_manually.patch [deleted file]
package/guile/guile-03-remove_unused_funcs.patch [deleted file]

diff --git a/package/guile/0001-fix_arm_endianness.patch b/package/guile/0001-fix_arm_endianness.patch
new file mode 100644 (file)
index 0000000..67c0b60
--- /dev/null
@@ -0,0 +1,25 @@
+Fix support for ARM endianness, otherwise it gives the error
+"unknown CPU endianness"
+
+Signed-off-by: Pedro Aguilar <paguilar@paguilar.org>
+
+diff -Nau guile-2.0.11.orig/module/system/base/target.scm guile-2.0.11/module/system/base/target.scm
+--- guile-2.0.11.orig/module/system/base/target.scm    2013-02-28 09:42:45.000000000 +0100
++++ guile-2.0.11/module/system/base/target.scm 2014-11-03 23:05:01.789338997 +0100
+@@ -70,7 +70,15 @@
+             ((member cpu '("sparc" "sparc64" "powerpc" "powerpc64" "spu"
+                            "mips" "mips64"))
+              (endianness big))
+-            ((string-match "^arm.*el" cpu)
++            ((string-match "^arm.*el" cpu)
++             (endianness little))
++            ((string-match "^arm.*eb" cpu)
++             (endianness big))
++            ((string-prefix? "arm" cpu)          ;ARMs are LE by default
++             (endianness little))
++            ((string-match "^aarch64.*be" cpu)
++             (endianness big))
++            ((string=? "aarch64" cpu)
+              (endianness little))
+             (else
+              (error "unknown CPU endianness" cpu)))))
diff --git a/package/guile/0002-calculate-csqrt_manually.patch b/package/guile/0002-calculate-csqrt_manually.patch
new file mode 100644 (file)
index 0000000..98bb0b6
--- /dev/null
@@ -0,0 +1,16 @@
+Avoid using scm_from_complex_double(csqrt()) when building with uclibc.
+
+Signed-off-by: Pedro Aguilar <paguilar@paguilar.org>
+
+diff -Nau guile-2.0.11.orig/configure.ac guile-2.0.11/configure.ac
+--- guile-2.0.11.orig/configure.ac     2014-03-12 14:36:02.000000000 +0100
++++ guile-2.0.11/configure.ac  2014-11-03 23:59:51.897267207 +0100
+@@ -862,7 +862,7 @@
+ }]])],
+     [guile_cv_use_csqrt=yes],
+     [guile_cv_use_csqrt="no, glibc 2.3 bug"],
+-    [guile_cv_use_csqrt="yes, hopefully (cross-compiling)"])])
++    [guile_cv_use_csqrt="no (cross-compiling)"])])
+   case $guile_cv_use_csqrt in
+     yes*)
+       AC_DEFINE([HAVE_USABLE_CSQRT], 1, [Define to 1 if csqrt is bug-free])
diff --git a/package/guile/0003-remove_unused_funcs.patch b/package/guile/0003-remove_unused_funcs.patch
new file mode 100644 (file)
index 0000000..3d70ee9
--- /dev/null
@@ -0,0 +1,36 @@
+Remove unused static inline functions str_upcase_l() and 
+str_downcase_l() that cause the compilation error:
+'dereferencing pointer to incomplete type'.
+
+Signed-off-by: Pedro Aguilar <paguilar@paguilar.org>
+
+diff -Nau guile-2.0.11.orig/libguile/i18n.c guile-2.0.11/libguile/i18n.c
+--- guile-2.0.11.orig/libguile/i18n.c  2014-01-21 22:25:11.000000000 +0100
++++ guile-2.0.11/libguile/i18n.c       2014-11-04 23:18:52.675435613 +0100
+@@ -851,26 +851,6 @@
+   *dst = '\0';
+ }
+-#ifdef USE_GNU_LOCALE_API
+-static inline void
+-str_upcase_l (register char *dst, register const char *src,
+-            scm_t_locale locale)
+-{
+-  for (; *src != '\0'; src++, dst++)
+-    *dst = toupper_l (*src, locale);
+-  *dst = '\0';
+-}
+-
+-static inline void
+-str_downcase_l (register char *dst, register const char *src,
+-              scm_t_locale locale)
+-{
+-  for (; *src != '\0'; src++, dst++)
+-    *dst = tolower_l (*src, locale);
+-  *dst = '\0';
+-}
+-#endif
+-
+ SCM_DEFINE (scm_string_locale_lt, "string-locale<?", 2, 1, 0,
+           (SCM s1, SCM s2, SCM locale),
diff --git a/package/guile/guile-01-fix_arm_endianness.patch b/package/guile/guile-01-fix_arm_endianness.patch
deleted file mode 100644 (file)
index 67c0b60..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-Fix support for ARM endianness, otherwise it gives the error
-"unknown CPU endianness"
-
-Signed-off-by: Pedro Aguilar <paguilar@paguilar.org>
-
-diff -Nau guile-2.0.11.orig/module/system/base/target.scm guile-2.0.11/module/system/base/target.scm
---- guile-2.0.11.orig/module/system/base/target.scm    2013-02-28 09:42:45.000000000 +0100
-+++ guile-2.0.11/module/system/base/target.scm 2014-11-03 23:05:01.789338997 +0100
-@@ -70,7 +70,15 @@
-             ((member cpu '("sparc" "sparc64" "powerpc" "powerpc64" "spu"
-                            "mips" "mips64"))
-              (endianness big))
--            ((string-match "^arm.*el" cpu)
-+            ((string-match "^arm.*el" cpu)
-+             (endianness little))
-+            ((string-match "^arm.*eb" cpu)
-+             (endianness big))
-+            ((string-prefix? "arm" cpu)          ;ARMs are LE by default
-+             (endianness little))
-+            ((string-match "^aarch64.*be" cpu)
-+             (endianness big))
-+            ((string=? "aarch64" cpu)
-              (endianness little))
-             (else
-              (error "unknown CPU endianness" cpu)))))
diff --git a/package/guile/guile-02-calculate-csqrt_manually.patch b/package/guile/guile-02-calculate-csqrt_manually.patch
deleted file mode 100644 (file)
index 98bb0b6..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-Avoid using scm_from_complex_double(csqrt()) when building with uclibc.
-
-Signed-off-by: Pedro Aguilar <paguilar@paguilar.org>
-
-diff -Nau guile-2.0.11.orig/configure.ac guile-2.0.11/configure.ac
---- guile-2.0.11.orig/configure.ac     2014-03-12 14:36:02.000000000 +0100
-+++ guile-2.0.11/configure.ac  2014-11-03 23:59:51.897267207 +0100
-@@ -862,7 +862,7 @@
- }]])],
-     [guile_cv_use_csqrt=yes],
-     [guile_cv_use_csqrt="no, glibc 2.3 bug"],
--    [guile_cv_use_csqrt="yes, hopefully (cross-compiling)"])])
-+    [guile_cv_use_csqrt="no (cross-compiling)"])])
-   case $guile_cv_use_csqrt in
-     yes*)
-       AC_DEFINE([HAVE_USABLE_CSQRT], 1, [Define to 1 if csqrt is bug-free])
diff --git a/package/guile/guile-03-remove_unused_funcs.patch b/package/guile/guile-03-remove_unused_funcs.patch
deleted file mode 100644 (file)
index 3d70ee9..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-Remove unused static inline functions str_upcase_l() and 
-str_downcase_l() that cause the compilation error:
-'dereferencing pointer to incomplete type'.
-
-Signed-off-by: Pedro Aguilar <paguilar@paguilar.org>
-
-diff -Nau guile-2.0.11.orig/libguile/i18n.c guile-2.0.11/libguile/i18n.c
---- guile-2.0.11.orig/libguile/i18n.c  2014-01-21 22:25:11.000000000 +0100
-+++ guile-2.0.11/libguile/i18n.c       2014-11-04 23:18:52.675435613 +0100
-@@ -851,26 +851,6 @@
-   *dst = '\0';
- }
--#ifdef USE_GNU_LOCALE_API
--static inline void
--str_upcase_l (register char *dst, register const char *src,
--            scm_t_locale locale)
--{
--  for (; *src != '\0'; src++, dst++)
--    *dst = toupper_l (*src, locale);
--  *dst = '\0';
--}
--
--static inline void
--str_downcase_l (register char *dst, register const char *src,
--              scm_t_locale locale)
--{
--  for (; *src != '\0'; src++, dst++)
--    *dst = tolower_l (*src, locale);
--  *dst = '\0';
--}
--#endif
--
- SCM_DEFINE (scm_string_locale_lt, "string-locale<?", 2, 1, 0,
-           (SCM s1, SCM s2, SCM locale),