ipmitool: Add option to enable usb interface
authorSam Mendoza-Jonas <sam@mendozajonas.com>
Thu, 20 Jul 2017 01:22:06 +0000 (11:22 +1000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 20 Jul 2017 21:05:22 +0000 (23:05 +0200)
Since ipmitool v1.8.17 usb support is turned off by default. Add a
config option to enable support for the usb interface.

Signed-off-by: Samuel Mendoza-Jonas <sam@mendozajonas.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ipmitool/Config.in
package/ipmitool/ipmitool.mk

index 1da0ace16f3a34aa7be79d5d4eb7ae8cc265cbdc..554a12cbd9fdc2e23e8f84192b5b1c25c66bf16d 100644 (file)
@@ -18,6 +18,12 @@ config BR2_PACKAGE_IPMITOOL_LANPLUS
          device using the OpenIPMI ipmi_si kernel module, or if using the
          legacy IPMI v1.5 RMCP LAN interface.
 
+config BR2_PACKAGE_IPMITOOL_USB
+       bool "enable usb interface"
+       help
+         Enables the IPMI USB interface typically used to send inband
+         IPMI commands to the BMC of a server.
+
 config BR2_PACKAGE_IPMITOOL_IPMIEVD
        bool "ipmievd"
        help
index b47209dba48d609e531e9816297510cd91042bef..5254668877a297e0fd8cce8881fb436e3a0803ac 100644 (file)
@@ -17,6 +17,12 @@ else
 IPMITOOL_CONF_OPTS += --disable-intf-lanplus
 endif
 
+ifeq ($(BR2_PACKAGE_IPMITOOL_USB),y)
+IPMITOOL_CONF_OPTS += --enable-intf-usb
+else
+IPMITOOL_CONF_OPTS += --disable-intf-usb
+endif
+
 ifeq ($(BR2_PACKAGE_IPMITOOL_IPMISHELL),y)
 IPMITOOL_DEPENDENCIES += ncurses readline
 IPMITOOL_CONF_OPTS += --enable-ipmishell