package/18xx-ti-utils: build/install wlconf as a host utility
authorMiken Valabdas <mvalabdas@distech-controls.com>
Wed, 16 Sep 2020 21:01:46 +0000 (17:01 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 17 Sep 2020 19:56:15 +0000 (21:56 +0200)
wlconf is build and installed as a host utility to be able to tweak
the wl18xx firmware configuration at build time.

Signed-off-by: Miken Valabdas <mvalabdas@distech-controls.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/18xx-ti-utils/18xx-ti-utils.mk

index d1f0388c3a876d156cb5bcf1367cdd1ea0d55c0f..625127d70944df25b84d678ebc9558e485290dba 100644 (file)
@@ -21,10 +21,14 @@ define 18XX_TI_UTILS_BUILD_CMDS
                NFSROOT="$(STAGING_DIR)" NLVER=3 $(MAKE) -C $(@D) \
                CFLAGS="$(TARGET_CFLAGS) $(18XX_TI_UTILS_CFLAGS)" \
                $(18XX_TI_UTILS_BUILD_TARGET)
+
+       $(HOST_MAKE_ENV) $(MAKE) -C $(@D)/wlconf \
+               $(HOST_CONFIGURE_OPTS)
 endef
 
 define 18XX_TI_UTILS_INSTALL_TARGET_CMDS
        $(INSTALL) -m 0755 $(@D)/calibrator $(TARGET_DIR)/usr/bin/calibrator
+       $(INSTALL) -m 0755 $(@D)/wlconf/wlconf $(HOST_DIR)/bin/wlconf
 endef
 
 $(eval $(generic-package))