package/opencv3: link with libatomic if needed
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 17 Oct 2020 13:46:23 +0000 (15:46 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 17 Oct 2020 16:24:50 +0000 (18:24 +0200)
Restore the atomic workaround that was wrongly removed when bumping to
version 3.4.9 in commit f6fb2cae0691d25b034b12a16261ee26096db7d1 as it
seems that opencv3 still needs help to detect atomic library

Fixes:
 - http://autobuild.buildroot.org/results/9162b29725f8d9b891eb74fcb8078f211140a841

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/opencv3/opencv3.mk

index de89aebca46f6b7a40e05ae45d450bd60a1a3595..648cc66af370e66fa4cabdadedce446fb32e4073 100644 (file)
@@ -13,6 +13,11 @@ OPENCV3_SUPPORTS_IN_SOURCE_BUILD = NO
 
 OPENCV3_CXXFLAGS = $(TARGET_CXXFLAGS)
 
+# Uses __atomic_fetch_add_4
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+OPENCV3_CXXFLAGS += -latomic
+endif
+
 # Fix c++11 build with missing std::exception_ptr
 ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_64735),y)
 OPENCV3_CXXFLAGS += -DCV__EXCEPTION_PTR=0