package/gstreamer1/gst1-plugins-bad: add sctp option
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 27 Feb 2021 08:25:22 +0000 (09:25 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Mar 2021 22:55:09 +0000 (23:55 +0100)
sctp unconditionnally uses __sync_*_4 intrinsics in
https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/blob/master/ext/sctp/usrsctp/usrsctplib/user_atomic.h

As a result, this will raise the following build failure with bootlin
sparc toolchain:

/srv/storage/autobuild/run/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/sparc-buildroot-linux-uclibc/9.3.0/../../../../sparc-buildroot-linux-uclibc/bin/ld: ext/sctp/usrsctp/libusrsctp-static.a(usrsctplib_user_socket.c.o): in function `usrsctp_conninput':
user_socket.c:(.text+0x3004): undefined reference to `__sync_fetch_and_add_4'

sctp uses an internal version of usrsctp (which is not available in
buildroot) and is available since version 1.15.1:
https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/commit/e2f06326eac7c3c7fa9c0d5baf4bf9673fc93376

Fixes:
 - http://autobuild.buildroot.org/results/981b11ae9746d1eef40c1797398c4f6c16f005bd

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index 191820df1dc77e3cea525918264f02c2a0371b15..628a9df42c39864f467991e91190427680207d26 100644 (file)
@@ -577,6 +577,10 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SBC
        bool "sbc"
        select BR2_PACKAGE_SBC
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SCTP
+       bool "sctp"
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4 # __sync_*_4 intrinsics
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SHM
        bool "shm"
        help
index 83abc7fab89c0ddeed631f9db06e09ee56baee83..e8cea5bb34cc67cad2fa4567d7a316b86962654d 100644 (file)
@@ -691,6 +691,16 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += -Dsbc=disabled
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SCTP),y)
+GST1_PLUGINS_BAD_CONF_OPTS += \
+       -Dsctp=enabled \
+       -Dsctp-internal-usrsctp=enabled
+else
+GST1_PLUGINS_BAD_CONF_OPTS += \
+       -Dsctp=disabled \
+       -Dsctp-internal-usrsctp=disabled
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SHM),y)
 GST1_PLUGINS_BAD_CONF_OPTS += -Dshm=enabled
 else