proftpd: Add ftp user creation
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Sun, 4 Oct 2015 13:31:33 +0000 (15:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 10 Oct 2015 17:27:38 +0000 (19:27 +0200)
In order to remove '/home/ftp' and the ftp user from the 'skeleton'
package, we need to add the creation of the ftp users to the package so
it still work out of the box (with an anonymous user).

Signed-off-by Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/proftpd/proftpd.mk

index dec243d4564a680828d46fedb07f0c714a5b23bd..d040b8c721d3d1fc438045956033339726596431 100644 (file)
@@ -51,6 +51,10 @@ define PROFTPD_INSTALL_TARGET_CMDS
        $(INSTALL) -m 0644 -D $(@D)/sample-configurations/basic.conf $(TARGET_DIR)/etc/proftpd.conf
 endef
 
+define PROFTPD_USERS
+       ftp -1 ftp -1 * /home/ftp - - Anonymous FTP User
+endef
+
 define PROFTPD_INSTALL_INIT_SYSV
        $(INSTALL) -D -m 0755 package/proftpd/S50proftpd $(TARGET_DIR)/etc/init.d/S50proftpd
 endef