package/skeleton: remove legacy mkdir
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 3 Jan 2017 21:01:03 +0000 (22:01 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 25 Jul 2017 22:57:51 +0000 (00:57 +0200)
We've had this mkdir, in various forms, for aeons. It dates back to
the inception of Buildroot, at the dawn of ages, when the toolchain
support was still nascent. Evolution had it morph from /include, to
a tuple-prefixed directory and a symlink there-to, then back to the
/include directory, to the final /usr/include directory we've had
for the last 9 years.

Anything that wants to install headers is supposed to be creating
that directory beforehand; we don't need this legacy mkdir now.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/skeleton/skeleton.mk

index 4a66f6cecab2cacb56bad15bb65f2b9f1ef6d997..f5106f744964e2be9dc81133b244e1041c5389c0 100644 (file)
@@ -82,7 +82,6 @@ define SKELETON_INSTALL_STAGING_CMDS
        $(INSTALL) -d -m 0755 $(STAGING_DIR)/usr/lib
        $(INSTALL) -d -m 0755 $(STAGING_DIR)/usr/bin
        $(INSTALL) -d -m 0755 $(STAGING_DIR)/usr/sbin
-       $(INSTALL) -d -m 0755 $(STAGING_DIR)/usr/include
        $(call SYSTEM_USR_SYMLINKS_OR_DIRS,$(STAGING_DIR))
        $(call SYSTEM_LIB_SYMLINK,$(STAGING_DIR))
 endef