package/vte: add gnutls optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 13 Jul 2019 08:32:56 +0000 (10:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 14 Jul 2019 12:54:26 +0000 (14:54 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vte/vte.mk

index 90853cb4a52083a51eb0d4592bd2f3d2f30c5b23..031022fb51c3d4621f7ac8d071e7a52217189388 100644 (file)
@@ -10,6 +10,13 @@ VTE_SITE = http://ftp.gnome.org/pub/gnome/sources/vte/0.48
 VTE_DEPENDENCIES = host-pkgconf libgtk3 libxml2 pcre2
 VTE_LICENSE = LGPL-2.1+
 VTE_LICENSE_FILES = COPYING
-VTE_CONF_OPTS += --disable-introspection --without-gnutls --disable-vala
+VTE_CONF_OPTS += --disable-introspection --disable-vala
+
+ifeq ($(BR2_PACKAGE_GNUTLS),y)
+VTE_CONF_OPTS += --with-gnutls
+VTE_DEPENDENCIES += gnutls
+else
+VTE_CONF_OPTS += --without-gnutls
+endif
 
 $(eval $(autotools-package))