boot/arm-trusted-firmware: add optional host-dtc dependency
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 18 Mar 2020 20:50:05 +0000 (21:50 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 18 Mar 2020 21:24:56 +0000 (22:24 +0100)
Some ATF configurations, such as the ones for the STM32MP1 processor
family, require DTC during the build as Device Tree files are
used. Without dtc, the build fails:

/bin/sh: 1: dtc: not found
dtc version too old (), you need at least version 1.4.4
plat/st/stm32mp1/platform.mk:239: recipe for target 'check_dtc_version' failed
make[1]: *** [check_dtc_version] Error 1

To solve this, this commit implements a
BR2_TARGET_ARM_TRUSTED_FIRMWARE_NEEDS_DTC option, in a way that mimics
the BR2_TARGET_UBOOT_NEEDS_DTC option we already have for the U-Boot
package.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
boot/arm-trusted-firmware/Config.in
boot/arm-trusted-firmware/arm-trusted-firmware.mk

index 373591d4978608a97b9a476c8b4f2b8144d17ec9..737dc587e5fb49670ada8e9954f87a31e8a00a50 100644 (file)
@@ -160,4 +160,11 @@ config BR2_TARGET_ARM_TRUSTED_FIRMWARE_IMAGES
          Names of generated image files that are installed in the
          output images/ directory.
 
+config BR2_TARGET_ARM_TRUSTED_FIRMWARE_NEEDS_DTC
+       bool "Needs dtc"
+       select BR2_PACKAGE_HOST_DTC
+       help
+         Select this option if your ATF board configuration
+         requires the Device Tree compiler to be available.
+
 endif
index 34737018aa00a12b8b7c536184aefe2ccb2c1687..27f63a87fed3bafd5c76810fc450a57e10379747 100644 (file)
@@ -29,6 +29,10 @@ endif
 
 ARM_TRUSTED_FIRMWARE_INSTALL_IMAGES = YES
 
+ifeq ($(BR2_TARGET_ARM_TRUSTED_FIRMWARE_NEEDS_DTC),y)
+ARM_TRUSTED_FIRMWARE_DEPENDENCIES += host-dtc
+endif
+
 ARM_TRUSTED_FIRMWARE_PLATFORM = $(call qstrip,$(BR2_TARGET_ARM_TRUSTED_FIRMWARE_PLATFORM))
 
 ifeq ($(BR2_TARGET_ARM_TRUSTED_FIRMWARE_DEBUG),y)