package/multicat: Add package
authorJulian Scheel <julian@jusst.de>
Wed, 27 Jan 2016 08:40:11 +0000 (09:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 22:46:22 +0000 (23:46 +0100)
multicat is a simple and efficient multicast and transport stream manipulation
tool.

Signed-off-by: Julian Scheel <julian@jusst.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/multicat/Config.in [new file with mode: 0644]
package/multicat/multicat.hash [new file with mode: 0644]
package/multicat/multicat.mk [new file with mode: 0644]

index c69d632e509630b30d095ad5b47cc0da353d3dcd..dc6818436c9c6dfd2c4616f4abe91e22f5dee507 100644 (file)
@@ -28,6 +28,7 @@ menu "Audio and video applications"
        source "package/mpd-mpc/Config.in"
        source "package/mpg123/Config.in"
        source "package/mplayer/Config.in"
+       source "package/multicat/Config.in"
        source "package/musepack/Config.in"
        source "package/ncmpc/Config.in"
        source "package/on2-8170-libs/Config.in"
diff --git a/package/multicat/Config.in b/package/multicat/Config.in
new file mode 100644 (file)
index 0000000..8dfb6c1
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_MULTICAT
+       bool "multicat"
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       select BR2_PACKAGE_BITSTREAM
+       help
+         Simple and efficient multicast and transport stream manipulation.
+
+         http://www.videolan.org/projects/multicat.html
+
+comment 'multicat needs a toolchain w/ threads'
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/multicat/multicat.hash b/package/multicat/multicat.hash
new file mode 100644 (file)
index 0000000..38cf9d7
--- /dev/null
@@ -0,0 +1,4 @@
+# from https://get.videolan.org/multicat/2.1/multicat-2.1.tar.bz2.md5
+md5 2e3ecd8dee64f5bd32a61733d4cc2226 multicat-2.1.tar.bz2
+# locally calculated
+sha256 5eabe8d9a3dde452b2d348683cc7da213680551a9d4059c356f7319c6aa9b3d1 multicat-2.1.tar.bz2
diff --git a/package/multicat/multicat.mk b/package/multicat/multicat.mk
new file mode 100644 (file)
index 0000000..5909bc5
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# multicat
+#
+################################################################################
+
+MULTICAT_VERSION = 2.1
+MULTICAT_SOURCE = multicat-$(MULTICAT_VERSION).tar.bz2
+MULTICAT_SITE = https://get.videolan.org/multicat/$(MULTICAT_VERSION)
+MULTICAT_LICENSE = GPLv2+
+MULTICAT_LICENSE_FILES = COPYING
+
+MULTICAT_MAKE_ENV = $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS)
+
+define MULTICAT_BUILD_CMDS
+       $(MULTICAT_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
+define MULTICAT_INSTALL_TARGET_CMDS
+       $(MULTICAT_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) PREFIX=/usr install
+endef
+
+$(eval $(generic-package))