uclibc: don't install tools to staging when static
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 25 May 2014 22:12:56 +0000 (19:12 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Jul 2014 18:52:15 +0000 (20:52 +0200)
Don't try to install ld* tools to staging when it's a static build,
there's no point and it'll be broken once we build a purely-static
uclibc.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uclibc/uclibc.mk

index f88691afc158b95be8ca6995b1d79fcd2d49261d..0c04033f7606fd3164d13f00b66315d90111aea7 100644 (file)
@@ -513,8 +513,8 @@ define UCLIBC_INSTALL_TARGET_CMDS
        $(UCLIBC_INSTALL_TEST_SUITE)
 endef
 
-# For FLAT binfmts (static) there are no host utils
-ifeq ($(BR2_BINFMT_FLAT),)
+# STATIC has no ld* tools, only getconf
+ifeq ($(BR2_PREFER_STATIC_LIB),)
 define UCLIBC_INSTALL_UTILS_STAGING
        $(INSTALL) -D -m 0755 $(@D)/utils/ldd.host $(HOST_DIR)/usr/bin/ldd
        ln -sf ldd $(HOST_DIR)/usr/bin/$(GNU_TARGET_NAME)-ldd