package/libiscsi: add optional dependency to cunit
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 4 Dec 2018 10:25:00 +0000 (11:25 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 6 Dec 2018 20:21:03 +0000 (21:21 +0100)
libiscsi uses cunit for its test suite, and autodetects its presence.

Usually, we just try to disable tests altogether, but there is no way to
do so. So, ensure proper ordering.

Note: there is an ac_cv_have_cunit variable, but it is not a true
ac_cv* cache variable, and the value provided on the command line or
environment is properly ignored.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libiscsi/libiscsi.mk

index a34069d7bff3d30ec7c2dd72b025a68fba09c6d8..2b26a1427c2be49715b193785f6f45f50e27f018 100644 (file)
@@ -11,6 +11,10 @@ LIBISCSI_LICENSE_FILES = COPYING LICENCE-GPL-2.txt LICENCE-LGPL-2.1.txt
 LIBISCSI_INSTALL_STAGING = YES
 LIBISCSI_AUTORECONF = YES
 
+ifeq ($(BR2_PACKAGE_CUNIT),y)
+LIBISCSI_DEPENDENCIES += cunit
+endif
+
 LIBISCSI_CONF_OPTS = --disable-werror --disable-manpages
 
 # We need to create the m4 directory to make autoreconf work properly.