package/paho-mqtt-c: drop dynamic library dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 18 Jun 2020 20:38:56 +0000 (22:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 20 Jun 2020 19:53:04 +0000 (21:53 +0200)
paho-mqtt-c can be built statically since version 1.3.3 and
https://github.com/eclipse/paho.mqtt.c/commit/f1459fac2532658a04962ae0ab67b5c3dc92ad75

See https://github.com/eclipse/paho.mqtt.c/issues/848

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/janus-gateway/Config.in
package/paho-mqtt-c/Config.in
package/paho-mqtt-c/paho-mqtt-c.mk

index fc32546717516e03c36927490d4a221c369ad290..136e6f0b20b25fddb221e271be3fa7e3f8b35d23 100644 (file)
@@ -59,12 +59,11 @@ comment "transports"
 
 config BR2_PACKAGE_JANUS_GATEWAY_MQTT
        bool "MQTT"
-       depends on !BR2_STATIC_LIBS
        depends on BR2_TOOLCHAIN_HAS_THREADS
        select BR2_PACKAGE_PAHO_MQTT_C
 
-comment "MQTT transport needs a toolchain w/ threads and dynamic library support"
-       depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
+comment "MQTT transport needs a toolchain w/ threads"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
 
 config BR2_PACKAGE_JANUS_GATEWAY_RABBITMQ
        bool "RabbitMQ"
index 3560d8c08cd37748c7997f13abf5ad6060be2840..0f4b2a29b2b8af613d76903ef7d1ca9b07fc87ce 100644 (file)
@@ -1,11 +1,10 @@
 config BR2_PACKAGE_PAHO_MQTT_C
        bool "paho-mqtt-c"
-       depends on !BR2_STATIC_LIBS  # dlopen()
        depends on BR2_TOOLCHAIN_HAS_THREADS
        help
          MQTT client C library
 
          https://eclipse.org/paho/clients/c/
 
-comment "paho-mqtt-c needs a toolchain w/ threads and dynamic library support"
-       depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
+comment "paho-mqtt-c needs a toolchain w/ threads"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
index aa2a0b026e90dacbd4d7ee879c489e59fd5a0894..984c512bbcbec71fa355146d013f4b25cc613067 100644 (file)
@@ -22,4 +22,18 @@ else
 PAHO_MQTT_C_CONF_OPTS += -DPAHO_WITH_SSL=FALSE
 endif
 
+ifeq ($(BR2_SHARED_LIBS),y)
+PAHO_MQTT_C_CONF_OPTS += \
+       -DPAHO_BUILD_SHARED=TRUE \
+       -DPAHO_BUILD_STATIC=FALSE
+else ifeq ($(BR2_STATIC_LIBS),y)
+PAHO_MQTT_C_CONF_OPTS += \
+       -DPAHO_BUILD_SHARED=FALSE \
+       -DPAHO_BUILD_STATIC=TRUE
+else ifeq ($(BR2_SHARED_STATIC_LIBS),y)
+PAHO_MQTT_C_CONF_OPTS += \
+       -DPAHO_BUILD_SHARED=TRUE \
+       -DPAHO_BUILD_STATIC=TRUE
+endif
+
 $(eval $(cmake-package))